summaryrefslogtreecommitdiffstats
path: root/package/sdl
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-16 11:18:11 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-17 00:09:35 +0200
commit66264b87557b32d379389d1e4f6d8c98ef887ee5 (patch)
tree0786bf823e6820f3124fecb750690908d198694a /package/sdl
parentab7d4fb421d7d765f832cd4c7fd8cb10004b8a70 (diff)
downloadbuildroot-novena-66264b87557b32d379389d1e4f6d8c98ef887ee5.tar.gz
buildroot-novena-66264b87557b32d379389d1e4f6d8c98ef887ee5.zip
sdl: fix build of other sdl components
The post installation hook of SDL was not being executed, due to an incorrect usage of the infrastructure. Moreover, it did not patch prefix/exec_prefix in sdl-config as is needed. In addition to that, we remove the -Wl,-rpath option from sdl-config, since it is not needed. This fixes at least the build of sdl_image, and probably of other sdl components as well. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sdl')
-rw-r--r--package/sdl/sdl.mk14
1 files changed, 11 insertions, 3 deletions
diff --git a/package/sdl/sdl.mk b/package/sdl/sdl.mk
index 87c753370..38341374b 100644
--- a/package/sdl/sdl.mk
+++ b/package/sdl/sdl.mk
@@ -46,11 +46,19 @@ SDL_CONF_OPT += --enable-pulseaudio=no \
--disable-esd \
--disable-nasm
-define SDL_POST_INSTALL_STAGING_HOOKS
- $(SED) 's^libdir=\$${exec_prefix}^libdir=/usr^' \
- $(STAGING_DIR)/usr/bin/sdl-config
+# Fixup prefix= and exec_prefix= in sdl-config, and remove the
+# -Wl,-rpath option.
+define SDL_FIXUP_SDL_CONFIG
+ $(SED) 's%prefix=/usr%prefix=$(STAGING_DIR)/usr%' \
+ $(STAGING_DIR)/usr/bin/sdl-config
+ $(SED) 's%exec_prefix=/usr%exec_prefix=$(STAGING_DIR)/usr%' \
+ $(STAGING_DIR)/usr/bin/sdl-config
+ $(SED) 's%-Wl,-rpath,\$${libdir}%%' \
+ $(STAGING_DIR)/usr/bin/sdl-config
endef
+SDL_POST_INSTALL_STAGING_HOOKS+=SDL_FIXUP_SDL_CONFIG
+
define SDL_INSTALL_TARGET_CMDS
cp -dpf $(STAGING_DIR)/usr/lib/libSDL*.so* $(TARGET_DIR)/usr/lib/
endef