summaryrefslogtreecommitdiffstats
path: root/package/scons
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-10-09 12:25:56 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-11 22:28:18 +0200
commitb08979477d65203b9b90c88d2a00246342c0b56a (patch)
treea45d88adec41d9b66263331302e16593091c839d /package/scons
parentf9d2bcd142e7162cabfa2153578eccc84e677d54 (diff)
downloadbuildroot-novena-b08979477d65203b9b90c88d2a00246342c0b56a.tar.gz
buildroot-novena-b08979477d65203b9b90c88d2a00246342c0b56a.zip
scons: fix library installation directory
On gentoo systems SCons setup.py tries to install into $(HOST_DIR)/usr/lib64 but SCons looks up for its stuff in $(HOST_DIR)/usr/lib instead hence breaking. Make it install into $(HOST_DIR)/usr/lib by force to avoid the issue, it shouldn't matter on other distributions. Version bumping doesn't fix it. [Peter: wrapped long line] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/scons')
-rw-r--r--package/scons/scons.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/scons/scons.mk b/package/scons/scons.mk
index 2aed62c5c..7cc234e8b 100644
--- a/package/scons/scons.mk
+++ b/package/scons/scons.mk
@@ -7,7 +7,8 @@ define HOST_SCONS_BUILD_CMDS
endef
define HOST_SCONS_INSTALL_CMDS
- (cd $(@D); python setup.py install --prefix=$(HOST_DIR)/usr)
+ (cd $(@D); python setup.py install --prefix=$(HOST_DIR)/usr \
+ --install-lib=$(HOST_DIR)/usr/lib/scons-$(SCONS_VERSION))
endef
$(eval $(host-generic-package))