summaryrefslogtreecommitdiffstats
path: root/package/sconeserver
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-09-20 22:20:34 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-08 22:58:20 +0200
commit76b38f853d2683854bfedaccb3512fab110c5d49 (patch)
tree00b5d32e62d0d9a02303f9c27095416921d9ea16 /package/sconeserver
parent42f0a84efd2cf511f331114db9167d00283c1425 (diff)
downloadbuildroot-novena-76b38f853d2683854bfedaccb3512fab110c5d49.tar.gz
buildroot-novena-76b38f853d2683854bfedaccb3512fab110c5d49.zip
sconeserver: new package
Signed-off-by: Simon Dawson <spdawson@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sconeserver')
-rw-r--r--package/sconeserver/Config.in88
-rw-r--r--package/sconeserver/sconeserver.mk116
2 files changed, 204 insertions, 0 deletions
diff --git a/package/sconeserver/Config.in b/package/sconeserver/Config.in
new file mode 100644
index 000000000..a7e5c7563
--- /dev/null
+++ b/package/sconeserver/Config.in
@@ -0,0 +1,88 @@
+menuconfig BR2_PACKAGE_SCONESERVER
+ bool "sconeserver"
+ depends on BR2_INSTALL_LIBSTDCPP
+ select BR2_PACKAGE_PCRE
+ help
+ Sconeserver is a modular, object-orientated and extremely versatile
+ network server framework for GNU/Linux and UNIX-like platforms.
+
+ http://www.sconemad.com/sconeserver/
+
+if BR2_PACKAGE_SCONESERVER
+
+comment "Sconeserver modules"
+
+config BR2_PACKAGE_SCONESERVER_EXAMPLES
+ bool "examples"
+ help
+ Example modules for Sconeserver
+
+config BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE
+ bool "http::sconesite"
+ select BR2_PACKAGE_LIBXML2
+ help
+ http::sconesite module for Sconeserver
+
+config BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE
+ bool "http::sconesite::image"
+ depends on BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE
+ select BR2_PACKAGE_IMAGEMAGICK
+ help
+ http::sconesite::image module for Sconeserver
+
+config BR2_PACKAGE_SCONESERVER_MYSQL
+ bool "mysql"
+ select BR2_PACKAGE_MYSQL_CLIENT
+ help
+ MySQL module for Sconeserver
+
+config BR2_PACKAGE_SCONESERVER_BLUETOOTH
+ bool "bluetooth"
+ select BR2_PACKAGE_BLUEZ_UTILS
+ help
+ Bluetooth module for Sconeserver
+
+config BR2_PACKAGE_SCONESERVER_RSS
+ bool "rss"
+ select BR2_PACKAGE_LIBXML2
+ help
+ RSS module for Sconeserver
+
+config BR2_PACKAGE_SCONESERVER_LOCATION
+ bool "location"
+ select BR2_PACKAGE_GPSD
+ help
+ Location module for Sconeserver
+
+config BR2_PACKAGE_SCONESERVER_LETTUCE
+ bool "lettuce"
+ help
+ Sconeserver module for Lettuce embedded automation platform
+
+ http://www.sconemad.com/lettuce/
+
+config BR2_PACKAGE_SCONESERVER_MATHS
+ bool "maths"
+ select BR2_PACKAGE_MPFR
+ help
+ Mathematics module for Sconeserver
+
+config BR2_PACKAGE_SCONESERVER_TESTBUILDER
+ bool "testbuilder"
+ help
+ Testbuilder module for Sconeserver
+
+config BR2_PACKAGE_SCONESERVER_UI
+ bool "ui"
+ depends on BR2_PACKAGE_XORG7
+ select BR2_PACKAGE_XLIB_LIBX11
+ help
+ UI module for Sconeserver
+
+comment "ui module requires X.org"
+ depends on !BR2_PACKAGE_XORG7
+
+endif # BR2_PACKAGE_SCONESERVER
+
+comment "sconeserver requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/sconeserver/sconeserver.mk b/package/sconeserver/sconeserver.mk
new file mode 100644
index 000000000..2313cd2e6
--- /dev/null
+++ b/package/sconeserver/sconeserver.mk
@@ -0,0 +1,116 @@
+#############################################################
+#
+# sconeserver
+#
+#############################################################
+# Release 0.6.0 doesn't build cleanly, so use a recent
+# Subversion trunk snapshot.
+SCONESERVER_VERSION = 178
+SCONESERVER_SITE = \
+ https://sconeserver.svn.sourceforge.net/svnroot/sconeserver/trunk
+SCONESERVER_SITE_METHOD = svn
+
+SCONESERVER_LICENSE = GPLv2+
+SCONESERVER_LICENSE_FILES = COPYING
+
+SCONESERVER_DEPENDENCIES += pcre
+SCONESERVER_CONF_OPT += --with-ip --with-local
+
+SCONESERVER_CONF_OPT += CXXFLAGS="$(TARGET_CXXFLAGS) $(SCONESERVER_CXXFLAGS)"
+SCONESERVER_CONF_OPT += LDFLAGS="$(TARGET_LDFLAGS) $(SCONESERVER_LDFLAGS)"
+
+# Sconeserver configure script fails to find the libxml2 headers.
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+ SCONESERVER_CXXFLAGS += -I$(STAGING_DIR)/usr/include/libxml2
+endif
+
+ifeq ($(BR2_INET_IPV6),y)
+ SCONESERVER_CONF_OPT += --with-ip6
+else
+ SCONESERVER_CONF_OPT += --without-ip6
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ SCONESERVER_DEPENDENCIES += openssl
+ SCONESERVER_CONF_OPT += --with-ssl
+else
+ SCONESERVER_CONF_OPT += --without-ssl
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_EXAMPLES),y)
+ SCONESERVER_CONF_OPT += --with-examples
+else
+ SCONESERVER_CONF_OPT += --without-examples
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE),y)
+ SCONESERVER_DEPENDENCIES += libxml2
+ SCONESERVER_CONF_OPT += --with-sconesite
+else
+ SCONESERVER_CONF_OPT += --without-sconesite
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE),y)
+ SCONESERVER_DEPENDENCIES += imagemagick
+ SCONESERVER_CONF_OPT += --with-sconesite-image
+else
+ SCONESERVER_CONF_OPT += --without-sconesite-image
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_MYSQL),y)
+ SCONESERVER_DEPENDENCIES += mysql_client
+ SCONESERVER_CONF_OPT += --with-mysql
+ SCONESERVER_CXXFLAGS += -I$(STAGING_DIR)/usr/include/mysql
+ SCONESERVER_LDFLAGS += -L$(STAGING_DIR)/usr/lib/mysql
+else
+ SCONESERVER_CONF_OPT += --without-mysql
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_BLUETOOTH),y)
+ SCONESERVER_DEPENDENCIES += bluez_utils
+ SCONESERVER_CONF_OPT += --with-bluetooth
+else
+ SCONESERVER_CONF_OPT += --without-bluetooth
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_RSS),y)
+ SCONESERVER_DEPENDENCIES += libxml2
+ SCONESERVER_CONF_OPT += --with-rss
+else
+ SCONESERVER_CONF_OPT += --without-rss
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_LOCATION),y)
+ SCONESERVER_DEPENDENCIES += gpsd
+ SCONESERVER_CONF_OPT += --with-location
+else
+ SCONESERVER_CONF_OPT += --without-location
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_LETTUCE),y)
+ SCONESERVER_CONF_OPT += --with-lettuce
+else
+ SCONESERVER_CONF_OPT += --without-lettuce
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_MATHS),y)
+ SCONESERVER_DEPENDENCIES += mpfr
+ SCONESERVER_CONF_OPT += --with-maths
+else
+ SCONESERVER_CONF_OPT += --without-maths
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_TESTBUILDER),y)
+ SCONESERVER_CONF_OPT += --with-testbuilder
+else
+ SCONESERVER_CONF_OPT += --without-testbuilder
+endif
+
+ifeq ($(BR2_PACKAGE_SCONESERVER_UI),y)
+ SCONESERVER_DEPENDENCIES += xlib_libX11
+ SCONESERVER_CONF_OPT += --with-ui
+else
+ SCONESERVER_CONF_OPT += --without-ui
+endif
+
+$(eval $(autotools-package))