summaryrefslogtreecommitdiffstats
path: root/package/sconeserver
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-12-06 05:12:50 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-16 01:10:11 +0100
commit6b8bbd323b01281a9eee7c58ca0a9ac9230f545e (patch)
tree51cd1ae985d2e2f22e89c9cd63f4aa35c1cb4ff9 /package/sconeserver
parentefddfcbe6dc531145fe3f4d7a39818e8e27d77b9 (diff)
downloadbuildroot-novena-6b8bbd323b01281a9eee7c58ca0a9ac9230f545e.tar.gz
buildroot-novena-6b8bbd323b01281a9eee7c58ca0a9ac9230f545e.zip
sconeserver: fix imagemagick build failures
The sconeserver configure script uses Magick++-config to obtain compiler and linker arguments for the imagemagick libraries. This doesn't work in Buildroot, and causes build failures such as the following http://autobuild.buildroot.net/results/7833edd60bbb2c291aea1efb5ccf407da7f4a51f/build-end.log The upstream sconeserver code has been changed to use pkg-config directly, instead of Magick++-config; this patch adapts the sconeserver package to the upstream change. Both this patch and the associated upstream change are based on a Buildroot patch submitted by Samuel Martin: http://patchwork.ozlabs.org/patch/200901/ Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sconeserver')
-rw-r--r--package/sconeserver/sconeserver.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/sconeserver/sconeserver.mk b/package/sconeserver/sconeserver.mk
index 15a1edc77..ab3d1fc99 100644
--- a/package/sconeserver/sconeserver.mk
+++ b/package/sconeserver/sconeserver.mk
@@ -5,7 +5,7 @@
#############################################################
# Release 0.6.0 doesn't build cleanly, so use a recent
# Subversion trunk snapshot.
-SCONESERVER_VERSION = 180
+SCONESERVER_VERSION = 183
SCONESERVER_SITE = \
https://sconeserver.svn.sourceforge.net/svnroot/sconeserver/trunk
SCONESERVER_SITE_METHOD = svn
@@ -51,7 +51,7 @@ else
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE),y)
- SCONESERVER_DEPENDENCIES += imagemagick
+ SCONESERVER_DEPENDENCIES += imagemagick host-pkgconf
SCONESERVER_CONF_OPT += --with-sconesite-image
else
SCONESERVER_CONF_OPT += --without-sconesite-image