summaryrefslogtreecommitdiffstats
path: root/package/samba
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-05-04 02:06:45 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-04 14:58:48 +0200
commite5627bd798a2291f36326558d7cbe1e8f6bb01e1 (patch)
tree012ac2a09179ad715504bf3262438f32945070e5 /package/samba
parentae47deffa16d5a78e790696a189bfb023c3754cb (diff)
downloadbuildroot-novena-e5627bd798a2291f36326558d7cbe1e8f6bb01e1.tar.gz
buildroot-novena-e5627bd798a2291f36326558d7cbe1e8f6bb01e1.zip
samba: add option for built-in debug messages
This option allows users to specify the maximum level for compiled-in debug messages with -1 being none. In a typical scenario of nmbd+smbd+smbpasswd this can save a full megabyte of target space. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/samba')
-rw-r--r--package/samba/Config.in8
-rw-r--r--package/samba/samba.mk3
2 files changed, 11 insertions, 0 deletions
diff --git a/package/samba/Config.in b/package/samba/Config.in
index fedbccdd6..0ab67edbb 100644
--- a/package/samba/Config.in
+++ b/package/samba/Config.in
@@ -13,6 +13,14 @@ config BR2_PACKAGE_SAMBA
if BR2_PACKAGE_SAMBA
+config BR2_PACKAGE_SAMBA_MAX_DEBUGLEVEL
+ int "Maximum level of compiled-in debug messages"
+ range -1 10000
+ default -1
+ help
+ Define the level of compiled-in debug messages.
+ This allows for big space savings, -1 being the lowest (none).
+
config BR2_PACKAGE_SAMBA_LIBICONV
bool "extended encodings (libiconv)"
depends on !BR2_ENABLE_LOCALE
diff --git a/package/samba/samba.mk b/package/samba/samba.mk
index 3a004e1d5..683c7b2e0 100644
--- a/package/samba/samba.mk
+++ b/package/samba/samba.mk
@@ -158,6 +158,9 @@ else
SAMBA_CONF_OPT += --with-libiconv=""
endif
+# Compiled debug messages by level
+SAMBA_CONF_OPT += CFLAGS="$(TARGET_CFLAGS) -DMAX_DEBUG_LEVEL=$(BR2_PACKAGE_SAMBA_MAX_DEBUGLEVEL)"
+
ifeq ($(BR2_PACKAGE_SAMBA_SWAT),y)
ifneq ($(BR2_HAVE_DOCUMENTATION),y)
SAMBA_POST_INSTALL_TARGET_HOOKS += SAMBA_REMOVE_SWAT_DOCUMENTATION