summaryrefslogtreecommitdiffstats
path: root/package/samba
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 13:41:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 22:18:56 +0200
commit9e06a8561665feb2c41e7a608b6849ac49ef0265 (patch)
tree9042be28c16d9c8d1e61be96da37c7a0734cecc0 /package/samba
parent9abe052f0438ea106274dd3dcbe34736460245a5 (diff)
downloadbuildroot-novena-9e06a8561665feb2c41e7a608b6849ac49ef0265.tar.gz
buildroot-novena-9e06a8561665feb2c41e7a608b6849ac49ef0265.zip
samba: remove swat documentation when not needed
When SWAT (the Web administration tool of Samba) is enabled, which is the default when one enables samba in Buildroot, a lot of documentation gets installed in /usr/swat (~15 MB). This patch fixes this by removing the documentation when BR2_HAVE_DOCUMENTATION is not set. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/samba')
-rw-r--r--package/samba/samba.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/samba/samba.mk b/package/samba/samba.mk
index 1c59070d4..44f7fdeff 100644
--- a/package/samba/samba.mk
+++ b/package/samba/samba.mk
@@ -161,6 +161,17 @@ $(SAMBA_HOOK_POST_INSTALL):
# remove unneeded
rm -f $(addprefix $(TARGET_DIR)/, $(SAMBA_BINTARGETS_))
rm -f $(addprefix $(TARGET_DIR)/, $(SAMBA_TXTTARGETS_))
+ifeq ($(BR2_PACKAGE_SAMBA_SWAT),y)
+ifneq ($(BR2_HAVE_DOCUMENTATION),y)
+ # Remove the documentation
+ rm -rf $(TARGET_DIR)/usr/swat/help/manpages
+ rm -rf $(TARGET_DIR)/usr/swat/help/Samba3*
+ rm -rf $(TARGET_DIR)/usr/swat/using_samba/
+ # Removing the welcome.html file will make swat default to
+ # welcome-no-samba-doc.html
+ rm -rf $(TARGET_DIR)/usr/swat/help/welcome.html
+endif
+endif
# strip binaries
$(STRIPCMD) $(STRIP_STRIP_ALL) $(addprefix $(TARGET_DIR)/, $(SAMBA_BINTARGETS_y))
# install start/stop script