summaryrefslogtreecommitdiffstats
path: root/package/ruby
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:43 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-29 23:12:27 +0200
commit300f9c9c9dcf2b47ea89c45d5b1ea05e7305bd49 (patch)
tree4b06e56a40777a04ec56ba16d9b5d08fed84de08 /package/ruby
parent0849e8193ef429f29945b8c2a54eafc8635e0969 (diff)
downloadbuildroot-novena-300f9c9c9dcf2b47ea89c45d5b1ea05e7305bd49.tar.gz
buildroot-novena-300f9c9c9dcf2b47ea89c45d5b1ea05e7305bd49.zip
package: remove useless arguments from AUTOTARGETS
Thanks to the pkgparentdir and pkgname functions, we can rewrite the AUTOTARGETS macro in a way that avoids the need for each package to repeat its name and the directory in which it is present. [Peter: pkgdir->pkgparentdir] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ruby')
-rw-r--r--package/ruby/ruby.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/ruby/ruby.mk b/package/ruby/ruby.mk
index 966a6a161..34953336f 100644
--- a/package/ruby/ruby.mk
+++ b/package/ruby/ruby.mk
@@ -31,5 +31,5 @@ ifeq ($(BR2_PACKAGE_ZLIB),y)
RUBY_DEPENDENCIES += zlib
endif
-$(eval $(call AUTOTARGETS,package,ruby))
-$(eval $(call AUTOTARGETS,package,ruby,host))
+$(eval $(call AUTOTARGETS))
+$(eval $(call AUTOTARGETS,host))