summaryrefslogtreecommitdiffstats
path: root/package/ruby
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-11-25 08:35:12 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-11-26 14:30:15 +0100
commit150124b9525c5db8f1f70e092ac6b00a7fb7e898 (patch)
tree1aa00d0799adb2d3bcbf2b82801497a8f9ee2f88 /package/ruby
parentfc11bb0ab4db4c44f50b8985b5d1a6f7ca7f5b84 (diff)
downloadbuildroot-novena-150124b9525c5db8f1f70e092ac6b00a7fb7e898.tar.gz
buildroot-novena-150124b9525c5db8f1f70e092ac6b00a7fb7e898.zip
ruby: fix host build breakage
When building host-ruby with ncurses enabled on an x86_64 host we get a "relocation R_X86_64_32 against `_nc_globals' can not be used when making a shared object; recompile with -fPIC" error when building. Just disable ncurses and readline support for the host version - we don't need it. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ruby')
-rw-r--r--package/ruby/ruby.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/ruby/ruby.mk b/package/ruby/ruby.mk
index a34a2512a..ad791f8f4 100644
--- a/package/ruby/ruby.mk
+++ b/package/ruby/ruby.mk
@@ -11,8 +11,7 @@ HOST_RUBY_AUTORECONF = YES
RUBY_DEPENDENCIES = host-ruby
RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
RUBY_CONF_OPT = --disable-install-doc --disable-rpath
-
-HOST_RUBY_CONF_OPT = --disable-install-doc
+HOST_RUBY_CONF_OPT = --disable-install-doc --without-ncurses --without-readline
# Force optionals to build before we do
ifeq ($(BR2_PACKAGE_BERKELEYDB),y)