summaryrefslogtreecommitdiffstats
path: root/package/rtorrent
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-05-14 10:55:29 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-14 23:00:59 +0200
commit54366d812d860aa7de776f14b00d52f89bb52371 (patch)
treeddb853783267bb65c3130d7301deae9bc039321b /package/rtorrent
parentbe26c3e760d86dbcc45ce6edd9e266a623c0430d (diff)
downloadbuildroot-novena-54366d812d860aa7de776f14b00d52f89bb52371.tar.gz
buildroot-novena-54366d812d860aa7de776f14b00d52f89bb52371.zip
rtorrent: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/rtorrent')
-rw-r--r--package/rtorrent/Config.in16
-rw-r--r--package/rtorrent/rtorrent-cross_compile.patch27
-rw-r--r--package/rtorrent/rtorrent.mk12
3 files changed, 55 insertions, 0 deletions
diff --git a/package/rtorrent/Config.in b/package/rtorrent/Config.in
new file mode 100644
index 000000000..142ff8b41
--- /dev/null
+++ b/package/rtorrent/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_RTORRENT
+ bool "rtorrent"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_WCHAR
+ select BR2_PACKAGE_LIBCURL
+ select BR2_PACKAGE_LIBSIGC
+ select BR2_PACKAGE_LIBTORRENT
+ select BR2_PACKAGE_NCURSES
+ select BR2_PACKAGE_OPENSSL
+ help
+ BitTorrent Client using libtorrent
+
+ http://libtorrent.rakshasa.no/
+
+comment "rtorrent requires a toolchain with C++ and WCHAR support"
+ depends on !(BR2_INSTALL_LIBSTDCPP && BR2_USE_WCHAR)
diff --git a/package/rtorrent/rtorrent-cross_compile.patch b/package/rtorrent/rtorrent-cross_compile.patch
new file mode 100644
index 000000000..2be8d0607
--- /dev/null
+++ b/package/rtorrent/rtorrent-cross_compile.patch
@@ -0,0 +1,27 @@
+Fix cross compilation, based on OpenWRT patch.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura rtorrent-0.9.2/configure.ac rtorrent-0.9.2-cross/configure.ac
+--- rtorrent-0.9.2/configure.ac 2012-04-20 03:55:30.000000000 -0300
++++ rtorrent-0.9.2-cross/configure.ac 2012-05-09 11:06:49.436474039 -0300
+@@ -4,7 +4,6 @@
+
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER(config.h)
+-AM_PATH_CPPUNIT(1.9.6)
+
+ AC_PROG_CXX
+ AC_PROG_LIBTOOL
+diff -Nura rtorrent-0.9.2/scripts/common.m4 rtorrent-0.9.2-cross/scripts/common.m4
+--- rtorrent-0.9.2/scripts/common.m4 2012-03-13 09:10:49.000000000 -0300
++++ rtorrent-0.9.2-cross/scripts/common.m4 2012-05-09 11:05:56.620102678 -0300
+@@ -223,7 +223,7 @@
+ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
+ AC_MSG_CHECKING(for execinfo.h)
+
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
++ AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <execinfo.h>
+ int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
+ ])],
diff --git a/package/rtorrent/rtorrent.mk b/package/rtorrent/rtorrent.mk
new file mode 100644
index 000000000..f60bd4072
--- /dev/null
+++ b/package/rtorrent/rtorrent.mk
@@ -0,0 +1,12 @@
+#############################################################
+#
+# rtorrent
+#
+#############################################################
+
+RTORRENT_VERSION = 0.9.2
+RTORRENT_SITE = http://libtorrent.rakshasa.no/downloads
+RTORRENT_DEPENDENCIES = host-pkg-config libcurl libsigc libtorrent ncurses
+RTORRENT_AUTORECONF = YES
+
+$(eval $(call AUTOTARGETS))