summaryrefslogtreecommitdiffstats
path: root/package/rsync
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/rsync
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
downloadbuildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/rsync')
-rw-r--r--package/rsync/Makefile.in3
-rw-r--r--package/rsync/rsync.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/rsync/Makefile.in b/package/rsync/Makefile.in
deleted file mode 100644
index 63e9acf67..000000000
--- a/package/rsync/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_RSYNC)),y)
-TARGETS+=rsync
-endif
diff --git a/package/rsync/rsync.mk b/package/rsync/rsync.mk
index b66125e94..735ce3a0e 100644
--- a/package/rsync/rsync.mk
+++ b/package/rsync/rsync.mk
@@ -46,3 +46,11 @@ rsync-clean:
rsync-dirclean:
rm -rf $(RSYNC_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_RSYNC)),y)
+TARGETS+=rsync
+endif