summaryrefslogtreecommitdiffstats
path: root/package/rsync
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-14 09:57:31 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-14 09:57:31 +0000
commit3f8f415a2af59b707c0db2fd0c1fa03e04316552 (patch)
tree47d948ac21b031df5d633a09d50ad0cdfaf07135 /package/rsync
parentc3da0d8281e24ad8fa1af7e06a16330cc6b41eb3 (diff)
downloadbuildroot-novena-3f8f415a2af59b707c0db2fd0c1fa03e04316552.tar.gz
buildroot-novena-3f8f415a2af59b707c0db2fd0c1fa03e04316552.zip
Teach rsync to compile
Diffstat (limited to 'package/rsync')
-rw-r--r--package/rsync/rsync.mk1
-rw-r--r--package/rsync/rsync.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/package/rsync/rsync.mk b/package/rsync/rsync.mk
index 10080d038..b66125e94 100644
--- a/package/rsync/rsync.mk
+++ b/package/rsync/rsync.mk
@@ -16,6 +16,7 @@ $(DL_DIR)/$(RSYNC_SOURCE):
$(RSYNC_DIR)/.unpacked: $(DL_DIR)/$(RSYNC_SOURCE)
$(RSYNC_CAT) $(DL_DIR)/$(RSYNC_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ toolchain/patch-kernel.sh $(RSYNC_DIR) package/rsync/ rsync*.patch
touch $(RSYNC_DIR)/.unpacked
$(RSYNC_DIR)/.configured: $(RSYNC_DIR)/.unpacked
diff --git a/package/rsync/rsync.patch b/package/rsync/rsync.patch
new file mode 100644
index 000000000..9c1927bdc
--- /dev/null
+++ b/package/rsync/rsync.patch
@@ -0,0 +1,11 @@
+--- rsync-2.6.3/rsync.orig.h 2004-10-14 03:49:54.000000000 -0600
++++ rsync-2.6.3/rsync.h 2004-10-14 03:50:09.000000000 -0600
+@@ -327,7 +327,7 @@
+ #define uint64 unsigned long long
+ #else
+ /* As long as it gets... */
+-#define uint64 unsigned off_t
++#define uint64 loff_t
+ #endif
+
+ /* Starting from protocol version 26, we always use 64-bit