summaryrefslogtreecommitdiffstats
path: root/package/rsh-redone
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-07 16:03:56 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-08 23:32:13 +0100
commitea7ab91c66dfceba414218c8156a347681b86df9 (patch)
tree3ce99435f29770c15bd6d12d0c7f8520666a687b /package/rsh-redone
parentd3d67f7fb527b3b549d9da0c67b42477a224b00b (diff)
downloadbuildroot-novena-ea7ab91c66dfceba414218c8156a347681b86df9.tar.gz
buildroot-novena-ea7ab91c66dfceba414218c8156a347681b86df9.zip
rsh-redone: new package for rsh/rlogin clients
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/rsh-redone')
-rw-r--r--package/rsh-redone/Config.in31
-rw-r--r--package/rsh-redone/rsh-redone.mk36
2 files changed, 67 insertions, 0 deletions
diff --git a/package/rsh-redone/Config.in b/package/rsh-redone/Config.in
new file mode 100644
index 000000000..454bf302b
--- /dev/null
+++ b/package/rsh-redone/Config.in
@@ -0,0 +1,31 @@
+config BR2_PACKAGE_RSH_REDONE
+ bool "rsh-redone"
+ help
+ Rsh-redone is a reimplementation of the remote shell clients and
+ servers. It is written from the ground up to avoid the bugs found
+ in the standard clients and servers. It also fully supports IPv6.
+
+ http://packages.debian.org/source/sid/rsh-redone
+
+# this is incomplete in the source
+#config BR2_PACKAGE_RSH_REDONE_RCP
+# bool "rcp"
+# depends on BR2_PACKAGE_RSH_REDONE
+
+config BR2_PACKAGE_RSH_REDONE_RLOGIN
+ bool "rlogin"
+ depends on BR2_PACKAGE_RSH_REDONE
+
+# requires PAM
+#config BR2_PACKAGE_RSH_REDONE_RLOGIND
+# bool "rlogind"
+# depends on BR2_PACKAGE_RSH_REDONE
+
+config BR2_PACKAGE_RSH_REDONE_RSH
+ bool "rsh"
+ depends on BR2_PACKAGE_RSH_REDONE
+
+# requires PAM
+#config BR2_PACKAGE_RSH_REDONE_RSHD
+# bool "rshd"
+# depends on BR2_PACKAGE_RSH_REDONE
diff --git a/package/rsh-redone/rsh-redone.mk b/package/rsh-redone/rsh-redone.mk
new file mode 100644
index 000000000..6217cb110
--- /dev/null
+++ b/package/rsh-redone/rsh-redone.mk
@@ -0,0 +1,36 @@
+#############################################################
+#
+# rsh-redone
+#
+#############################################################
+
+RSH_REDONE_VERSION = 85
+RSH_REDONE_SOURCE = rsh-redone_$(RSH_REDONE_VERSION).orig.tar.gz
+RSH_REDONE_SITE = $(BR2_DEBIAN_MIRROR)/debian/pool/main/r/rsh-redone
+
+rsh-redone-bin-y =
+rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RCP) += rcp
+rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RLOGIN) += rlogin
+rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RSH) += rsh
+rsh-redone-sbin-y =
+rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RLOGIND) += rlogind
+rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RSHD) += rshd
+
+define RSH_REDONE_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) BIN="$(rsh-redone-bin-y)" SBIN="$(rsh-redone-sbin-y)"
+endef
+
+define RSH_REDONE_INSTALL_TARGET_CMDS
+ $(if $(rsh-redone-bin-y)$(rsh-redone-sbin-y),
+ $(RSH_REDONE_BUILD_CMDS) DESTDIR=$(TARGET_DIR) \
+ $(if $(rsh-redone-bin-y),install-bin) \
+ $(if $(rsh-redone-sbin-y),install-sbin))
+endef
+
+define RSH_REDONE_UNINSTALL_TARGET_CMDS
+ rm -f \
+ $(addprefix $(TARGET_DIR)/usr/bin/,$(rsh-redone-bin-y)) \
+ $(addprefix $(TARGET_DIR)/usr/sbin/,$(rsh-redone-sbin-y))
+endef
+
+$(eval $(call GENTARGETS,package,rsh-redone))