summaryrefslogtreecommitdiffstats
path: root/package/rpi-userland
diff options
context:
space:
mode:
authorFloris Bos <bos@je-eigen-domein.nl>2013-03-07 10:18:33 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-09 22:25:41 +0100
commit2e1fb3f7c42817495e5b25fe0c85c655720c8d4e (patch)
treefe12fd59b74b1043b6cbd4098f22bc48f0be8598 /package/rpi-userland
parent2282b93f4248a32de84805456efa352f69b28624 (diff)
downloadbuildroot-novena-2e1fb3f7c42817495e5b25fe0c85c655720c8d4e.tar.gz
buildroot-novena-2e1fb3f7c42817495e5b25fe0c85c655720c8d4e.zip
rpi-userland: add bcm_host to egl.pc
bcm_host is the Broadcom hardware interface library And is currently a dependency to use the EGL functions Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/rpi-userland')
-rw-r--r--package/rpi-userland/rpi-userland-add-pkgconfig-files.patch7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/rpi-userland/rpi-userland-add-pkgconfig-files.patch b/package/rpi-userland/rpi-userland-add-pkgconfig-files.patch
index 0da9afd89..4ffc2b0bb 100644
--- a/package/rpi-userland/rpi-userland-add-pkgconfig-files.patch
+++ b/package/rpi-userland/rpi-userland-add-pkgconfig-files.patch
@@ -9,7 +9,7 @@ Index: b/interface/khronos/egl/egl.pc.in
===================================================================
--- /dev/null
+++ b/interface/khronos/egl/egl.pc.in
-@@ -0,0 +1,10 @@
+@@ -0,0 +1,11 @@
+prefix=@CMAKE_INSTALL_PREFIX@
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
@@ -18,8 +18,9 @@ Index: b/interface/khronos/egl/egl.pc.in
+Name: egl
+Description: RasberryPi implementation of EGL
+Version: 1.0
-+Libs: -L${libdir} -lEGL -lGLESv2
-+Cflags: -I${includedir}/ -I${includedir}/interface/vcos/pthreads/
++Libs: -L${libdir} -lEGL -lGLESv2 -lbcm_host
++Cflags: -I${includedir}/ -I${includedir}/interface/vcos/pthreads/ \
++ -I${includedir}/interface/vmcs_host/linux/
Index: b/interface/khronos/CMakeLists.txt
===================================================================
--- a/interface/khronos/CMakeLists.txt