summaryrefslogtreecommitdiffstats
path: root/package/redis/redis-001-uclibc.patch
diff options
context:
space:
mode:
authorDaniel Price <daniel.price@gmail.com>2013-03-11 15:47:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-18 22:42:02 +0100
commit80a902c407462dbd2d239ded97c2cdf66fae4a51 (patch)
tree868194db477000a6f030b8aa8d3c660aa1a90006 /package/redis/redis-001-uclibc.patch
parent96879b87a90d8c1e4de3c399a9e8df6dc4537180 (diff)
downloadbuildroot-novena-80a902c407462dbd2d239ded97c2cdf66fae4a51.tar.gz
buildroot-novena-80a902c407462dbd2d239ded97c2cdf66fae4a51.zip
new package: redis
[Peter: fix white space, drop _SOURCE] Signed-off-by: Daniel Price <daniel.price@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/redis/redis-001-uclibc.patch')
-rw-r--r--package/redis/redis-001-uclibc.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/redis/redis-001-uclibc.patch b/package/redis/redis-001-uclibc.patch
new file mode 100644
index 000000000..d7fd9c3c5
--- /dev/null
+++ b/package/redis/redis-001-uclibc.patch
@@ -0,0 +1,45 @@
+redis-001-uclibc.patch: This patch fixes redis so that it can be compiled
+against uclibc. Patch originates from:
+
+ Support cross-compiling for uClibc targets
+ https://github.com/antirez/redis/pull/537
+ Mike Steinert, mike.steinert@gmail.com
+
+Signed-off-by: Daniel Price <daniel.price@gmail.com>
+
+=========================================================================
+diff -ur old/src/config.h new/src/config.h
+--- old/src/config.h 2012-10-26 07:20:24.000000000 -0700
++++ new/src/config.h 2012-10-31 13:41:51.206309564 -0700
+@@ -1,6 +1,10 @@
+ #ifndef __CONFIG_H
+ #define __CONFIG_H
+
++#ifdef __unix
++#include <features.h>
++#endif
++
+ #ifdef __APPLE__
+ #include <AvailabilityMacros.h>
+ #endif
+@@ -25,7 +29,7 @@
+ #endif
+
+ /* Test for backtrace() */
+-#if defined(__APPLE__) || defined(__linux__)
++#if (defined(__APPLE__) || defined(__linux__) && !defined(__UCLIBC__))
+ #define HAVE_BACKTRACE 1
+ #endif
+
+diff -ur old/src/Makefile new/src/Makefile
+--- old/src/Makefile 2012-10-26 07:20:24.000000000 -0700
++++ new/src/Makefile 2012-10-31 13:40:39.224728830 -0700
+@@ -135,7 +135,7 @@
+ echo REDIS_LDFLAGS=$(REDIS_LDFLAGS) >> .make-settings
+ echo PREV_FINAL_CFLAGS=$(FINAL_CFLAGS) >> .make-settings
+ echo PREV_FINAL_LDFLAGS=$(FINAL_LDFLAGS) >> .make-settings
+- -(cd ../deps && $(MAKE) $(DEPENDENCY_TARGETS))
++ -(cd ../deps && $(MAKE) CC=$(CC) $(DEPENDENCY_TARGETS))
+
+ .PHONY: persist-settings
+