summaryrefslogtreecommitdiffstats
path: root/package/readline
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/readline
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/readline')
-rw-r--r--package/readline/readline.mk35
1 files changed, 15 insertions, 20 deletions
diff --git a/package/readline/readline.mk b/package/readline/readline.mk
index ff0a683ec..17f6c6386 100644
--- a/package/readline/readline.mk
+++ b/package/readline/readline.mk
@@ -22,13 +22,24 @@ $(READLINE_DIR)/.unpacked: $(DL_DIR)/$(READLINE_SOURCE)
$(READLINE_DIR)/.configured: $(READLINE_DIR)/.unpacked
(cd $(READLINE_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) CC_FOR_BUILD=$(HOSTCC) \
+ $(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
- --prefix=$(STAGING_DIR) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
);
touch $(READLINE_DIR)/.configured
@@ -43,30 +54,14 @@ $(STAGING_DIR)/$(READLINE_TARGET_BINARY): $(READLINE_DIR)/.configured
# Install to Staging area
$(STAGING_DIR)/include/readline/readline.h: $(READLINE_DIR)/$(READLINE_BINARY)
BUILD_CC=$(TARGET_CC) HOSTCC="$(HOSTCC)" CC=$(TARGET_CC) \
- $(MAKE1) \
- prefix=$(STAGING_DIR) \
- exec_prefix=$(STAGING_DIR) \
- bindir=$(STAGING_DIR)/bin \
- sbindir=$(STAGING_DIR)/sbin \
- libexecdir=$(STAGING_DIR)/lib \
- datadir=$(STAGING_DIR)/usr/share \
- sysconfdir=$(STAGING_DIR)/etc \
- localstatedir=$(STAGING_DIR)/var \
- libdir=$(STAGING_DIR)/lib \
- infodir=$(STAGING_DIR)/info \
- mandir=$(STAGING_DIR)/man \
- includedir=$(STAGING_DIR)/include \
- -C $(READLINE_DIR) install;
+ $(MAKE1) DESTDIR=$(STAGING_DIR) -C $(READLINE_DIR) install;
touch -c $(STAGING_DIR)/include/readline/readline.h
# Install only run-time to Target directory
$(TARGET_DIR)/include/readline/readline.h: $(READLINE_DIR)/$(READLINE_BINARY)
BUILD_CC=$(TARGET_CC) HOSTCC="$(HOSTCC)" CC=$(TARGET_CC) \
- $(MAKE1) \
- prefix=$(TARGET_DIR) \
- libdir=$(TARGET_DIR)/lib \
- -C $(READLINE_DIR) install-shared
+ $(MAKE1) DESTDIR=$(TARGET_DIR) -C $(READLINE_DIR) install-shared
touch -c $(TARGET_DIR)/include/readline/readline.h
readline: $(STAGING_DIR)/include/readline/readline.h