summaryrefslogtreecommitdiffstats
path: root/package/quagga
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-04-18 01:47:21 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-21 22:33:27 +0200
commit05554f1747bbc2b358819ced2b9d674be6d21db7 (patch)
tree07f7a710eb62b09ecbe53a6711cf2e4bef25fba7 /package/quagga
parent978e7c74aa3b54bf2d90c5d94594f649da2f45c3 (diff)
downloadbuildroot-novena-05554f1747bbc2b358819ced2b9d674be6d21db7.tar.gz
buildroot-novena-05554f1747bbc2b358819ced2b9d674be6d21db7.zip
quagga: fix build breakage without snmp
Quagga no longer supports explicitly disabling snmp, and what's worse, it interprets --disable-snmp as --enable-snmp. Remove the disable configure option. While at it add a comment about net-snmp requiring AgentX support for quagga to build properly as suggested by Arnout. Fixes: http://autobuild.buildroot.net/results/a9bce6dd8065ddb1850a4e14f0e4eb257ee89286/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/quagga')
-rw-r--r--package/quagga/Config.in3
-rw-r--r--package/quagga/quagga.mk4
2 files changed, 4 insertions, 3 deletions
diff --git a/package/quagga/Config.in b/package/quagga/Config.in
index 0834201d4..c364ae1b4 100644
--- a/package/quagga/Config.in
+++ b/package/quagga/Config.in
@@ -84,4 +84,7 @@ config BR2_PACKAGE_QUAGGA_SNMP
help
Make quagga information available via SNMP SMUX.
+comment "AgentX support must be enabled in net-snmp or the build will break"
+ depends on BR2_PACKAGE_QUAGGA_SNMP
+
endif
diff --git a/package/quagga/quagga.mk b/package/quagga/quagga.mk
index 42f8506b2..347ec4ddb 100644
--- a/package/quagga/quagga.mk
+++ b/package/quagga/quagga.mk
@@ -26,10 +26,8 @@ QUAGGA_CONF_OPT += $(if $(BR2_PACKAGE_QUAGGA_OPAQUE_LSA),--enable-opaque-lsa,--d
ifeq ($(BR2_PACKAGE_QUAGGA_SNMP),y)
QUAGGA_CONF_ENV += ac_cv_path_NETSNMP_CONFIG=$(STAGING_DIR)/usr/bin/net-snmp-config
-QUAGGA_CONF_OPT += --enable-snmp
+QUAGGA_CONF_OPT += --enable-snmp=agentx
QUAGGA_DEPENDENCIES += netsnmp
-else
-QUAGGA_CONF_OPT +=--disable-snmp
endif
$(eval $(autotools-package))