summaryrefslogtreecommitdiffstats
path: root/package/qt
diff options
context:
space:
mode:
authorMichael Roth <mroth@nessie.de>2009-10-07 11:20:33 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-09 14:42:51 +0200
commit51a3b74b6eee42e335b963b4f3ddbdaa9c6459b0 (patch)
tree387cbeebf9fdd4ee9395714b3ce7b0b21fe85f7c /package/qt
parent7f541e304778b85a3f9a07c8b3dadb3df5b2d35c (diff)
downloadbuildroot-novena-51a3b74b6eee42e335b963b4f3ddbdaa9c6459b0.tar.gz
buildroot-novena-51a3b74b6eee42e335b963b4f3ddbdaa9c6459b0.zip
qt: don't enable internal tslib-module debugging
In Qt there are virtually hundreds of internal debug flags like TSLIBMOUSEHANDLER_DEBUG for every module or even C++ class. There is no reason to enable a single such flag when Qt is build with debugging symbols and others not. Signed-off-by: Michael Roth <mroth@nessie.de> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/qt.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index e7c22c354..6c73e041e 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -153,8 +153,6 @@ endif
ifeq ($(BR2_PACKAGE_QT_MOUSE_TSLIB),y)
QT_CONFIGURE += -qt-mouse-tslib
QT_DEP_LIBS+=tslib
-QT_TSLIB_DEB="-D TSLIBMOUSEHANDLER_DEBUG"
-QT_TSLIB_DEB:=$(call qstrip,$(QT_TSLIB_DEB))
else
QT_CONFIGURE += -no-mouse-tslib
endif
@@ -165,7 +163,7 @@ QT_CONFIGURE += -no-mouse-qvfb
endif
ifeq ($(BR2_PACKAGE_QT_DEBUG),y)
-QT_CONFIGURE+= "-debug $(QT_TSLIB_DEB)"
+QT_CONFIGURE+= -debug
else
QT_CONFIGURE+= -release
endif