summaryrefslogtreecommitdiffstats
path: root/package/qt
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2013-02-18 09:39:32 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-18 22:27:05 +0100
commit4b6f552a070b378fb12b07756f1df35db745598b (patch)
treeee9814ffb04367a2781a2b6cc381c942ce25baa7 /package/qt
parente6f0a3bd5ff4bcbb5cc24a0c79f7669055a16a75 (diff)
downloadbuildroot-novena-4b6f552a070b378fb12b07756f1df35db745598b.tar.gz
buildroot-novena-4b6f552a070b378fb12b07756f1df35db745598b.zip
qt: disable precompiled headers to workaround compilation failure
Precompiled header implementation is buggy in current Qt as described at http://comments.gmane.org/gmane.comp.lib.qt.devel/5933. The only known workaround is currently to add -no-pch to configure. Fixes build failure terminating with error compiling ../3rdparty/pixman/pixman-arm-neon-asm.S cc1: fatal error: .pch/release-shared-emb-arm/QtGui: No such file or directory compilation terminated. such as: http://autobuild.buildroot.net/results/648265012591280fa592a239f86ee39aec2d5fa6/build-end.log Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/qt.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index ee1a88b7a..9f50f9135 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -416,10 +416,10 @@ else
QT_CONFIGURE_OPTS += -no-declarative
endif
-# ccache and precompiled headers don't play well together
-ifeq ($(BR2_CCACHE),y)
+# -no-pch is needed to workaround the issue described at
+# http://comments.gmane.org/gmane.comp.lib.qt.devel/5933.
+# In addition, ccache and precompiled headers don't play well together
QT_CONFIGURE_OPTS += -no-pch
-endif
# x86x86fix
# Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux