summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorFloris Bos <bos@je-eigen-domein.nl>2013-03-19 09:29:41 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-19 22:41:48 +0100
commitcdfa21b06041eb601e0bea79f2c8f50e9d637384 (patch)
tree2025f154e5c0b548d786bebd73ab5df231c9bc1b /package/qt5
parent6cd7b60f8bd2ad827028e3a82d2f62cf63831a99 (diff)
downloadbuildroot-novena-cdfa21b06041eb601e0bea79f2c8f50e9d637384.tar.gz
buildroot-novena-cdfa21b06041eb601e0bea79f2c8f50e9d637384.zip
qt5base: install bundled fonts to target
If not using font-config, Qt 5 offers a set of standard fonts to use instead. Install these to target. Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/qt5base.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 3b4c007a0..83ce9998c 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -172,9 +172,17 @@ define QT5BASE_INSTALL_TARGET_PLUGINS
fi
endef
+define QT5BASE_INSTALL_TARGET_FONTS
+ if [ -d $(STAGING_DIR)/usr/lib/fonts/ ] ; then \
+ mkdir -p $(TARGET_DIR)/usr/lib/fonts ; \
+ cp -dpfr $(STAGING_DIR)/usr/lib/fonts/* $(TARGET_DIR)/usr/lib/fonts ; \
+ fi
+endef
+
define QT5BASE_INSTALL_TARGET_CMDS
$(QT5BASE_INSTALL_TARGET_LIBS)
$(QT5BASE_INSTALL_TARGET_PLUGINS)
+ $(QT5BASE_INSTALL_TARGET_FONTS)
endef
$(eval $(generic-package))