summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-19 09:29:39 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-19 22:39:39 +0100
commit53fbd8a7c529ba307f6d693ceb1f42696cdf05d9 (patch)
tree9ccbfbe897574b3ed60393c2460bf37d3173da72 /package/qt5
parentf8ffed2dbe8312202169efba6182ba8bf76be026 (diff)
downloadbuildroot-novena-53fbd8a7c529ba307f6d693ceb1f42696cdf05d9.tar.gz
buildroot-novena-53fbd8a7c529ba307f6d693ceb1f42696cdf05d9.zip
qt5base: add support to build against ICU
Qt5Webkit requires Qt5Base to be built with ICU support, so we add such support. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/Config.in7
-rw-r--r--package/qt5/qt5base/qt5base.mk4
2 files changed, 10 insertions, 1 deletions
diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
index d313db918..797435711 100644
--- a/package/qt5/qt5base/Config.in
+++ b/package/qt5/qt5base/Config.in
@@ -140,4 +140,11 @@ config BR2_PACKAGE_QT5BASE_DBUS
help
This option enables the D-Bus module.
+config BR2_PACKAGE_QT5BASE_ICU
+ bool "Enable ICU support"
+ select BR2_PACKAGE_ICU
+ help
+ This option enables ICU support in Qt5. This is for example
+ needed for Qt5Webkit.
+
endif
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index d5dcb7d3f..ac63e9814 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -25,7 +25,6 @@ QT5BASE_CONFIGURE_OPTS += \
-no-nis \
-no-libudev \
-no-iconv \
- -no-icu \
-no-gstreamer \
-no-gtkstyle \
-system-zlib \
@@ -97,6 +96,9 @@ QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_DBUS),dbus)
QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_LIBGLIB2),-glib,-no-glib)
QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBGLIB2),libglib2)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_ICU),-icu,-no-icu)
+QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_ICU),icu)
+
# Build the list of libraries to be installed on the target
QT5BASE_INSTALL_LIBS_y += Qt5Core
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK) += Qt5Network