summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-19 09:29:34 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-19 22:07:09 +0100
commit52b7e7cbadae4a5d7cbcab1b6e19cfad77a114ff (patch)
treee57f41b2e58bb7a7057cbea03214c3184980780f /package/qt5
parent3216dca03bdaa5c25eeaa46f42fccf8f84ef0708 (diff)
downloadbuildroot-novena-52b7e7cbadae4a5d7cbcab1b6e19cfad77a114ff.tar.gz
buildroot-novena-52b7e7cbadae4a5d7cbcab1b6e19cfad77a114ff.zip
qt5base: add OpenSSL support
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/qt5base.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 33555aef3..736965d36 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -28,7 +28,6 @@ QT5BASE_CONFIGURE_OPTS += \
-no-nis \
-no-libudev \
-no-iconv \
- -no-openssl \
-no-fontconfig \
-no-gif \
-no-libpng \
@@ -82,6 +81,9 @@ else
QT5BASE_CONFIGURE_OPTS += -no-xcb
endif
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_OPENSSL),-openssl,-no-openssl)
+QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_OPENSSL),openssl)
+
# Build the list of libraries to be installed on the target
QT5BASE_INSTALL_LIBS_y += Qt5Core
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK) += Qt5Network