summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-06-02 16:33:05 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-02 16:33:05 +0200
commit1ba51d2fbddd5650f8caea0a327b9031238ad843 (patch)
tree05d5df7b487e76597b34cb0b1fc9543525169a62 /package/qt5
parent0c94aa549cc8cf483bc8c3443a2b1f772d5d180b (diff)
parentfb2f3d58bde6aaac12b62eeb16492c93329b8713 (diff)
downloadbuildroot-novena-1ba51d2fbddd5650f8caea0a327b9031238ad843.tar.gz
buildroot-novena-1ba51d2fbddd5650f8caea0a327b9031238ad843.zip
Merge branch 'next'
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/Config.in36
-rw-r--r--package/qt5/qt5base/qt5base.mk16
2 files changed, 52 insertions, 0 deletions
diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
index 797435711..9c7fd15da 100644
--- a/package/qt5/qt5base/Config.in
+++ b/package/qt5/qt5base/Config.in
@@ -43,6 +43,42 @@ config BR2_PACKAGE_QT5BASE_SQL
help
This options enables the Qt5Sql library.
+if BR2_PACKAGE_QT5BASE_SQL
+config BR2_PACKAGE_QT5BASE_MYSQL
+ bool "MySQL Plugin"
+ select BR2_PACKAGE_MYSQL_CLIENT
+ select BR2_PACKAGE_NCURSES
+ select BR2_PACKAGE_READLINE
+ depends on BR2_USE_MMU # mysql
+ help
+ Build MySQL plugin
+ If unsure, say n.
+choice
+ prompt "SQLite 3 support"
+ default BR2_PACKAGE_QT5BASE_SQLITE_NONE
+ help
+ Select SQLite support.
+
+config BR2_PACKAGE_QT5BASE_SQLITE_NONE
+ bool "No sqlite support"
+ help
+ Do not compile any kind of SQLite support.
+
+config BR2_PACKAGE_QT5BASE_SQLITE_QT
+ bool "Qt SQLite"
+ help
+ Use Qt bundled SQLite support.
+
+config BR2_PACKAGE_QT5BASE_SQLITE_SYSTEM
+ bool "System SQLite"
+ select BR2_PACKAGE_SQLITE
+ help
+ Use system SQLite.
+
+endchoice
+
+endif
+
config BR2_PACKAGE_QT5BASE_TEST
bool "test module"
help
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index bfc6c911e..cfa06ea1e 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -60,6 +60,21 @@ QT5BASE_LICENSE = Commercial license
QT5BASE_REDISTRIBUTE = NO
endif
+# Qt5 SQL Plugins
+ifeq ($(BR2_PACKAGE_QT5BASE_SQL),y)
+ifeq ($(BR2_PACKAGE_QT5BASE_MYSQL),y)
+QT5BASE_CONFIGURE_OPTS += -plugin-sql-mysql -mysql_config $(STAGING_DIR)/usr/bin/mysql_config
+QT5BASE_DEPENDENCIES += mysql_client
+else
+QT5BASE_CONFIGURE_OPTS += -no-sql-mysql
+endif
+
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_SQLITE_QT),-plugin-sql-sqlite)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_SQLITE_SYSTEM),-system-sqlite)
+QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5BASE_SQLITE_SYSTEM),sqlite)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_SQLITE_NONE),-no-sql-sqlite)
+endif
+
# We have to use --enable-linuxfb, otherwise Qt thinks that -linuxfb
# is to add a link against the "inuxfb" library.
QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_GUI),-gui,-no-gui)
@@ -118,6 +133,7 @@ QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_CONCURRENT) += Qt5Concurrent
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_SQL) += Qt5Sql
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_TEST) += Qt5Test
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_XML) += Qt5Xml
+QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_EGLFS) += Qt5OpenGL
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_GUI) += Qt5Gui
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_WIDGETS) += Qt5Widgets