summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-04-07 09:57:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-11 16:10:51 +0200
commit186ef9f6f4647ed34b67a3427a5e0e249f0794e7 (patch)
treed398d7f33af20be80b64420c15f1d0e792c08d0c /package/qt5
parent62c92adb5cfd46eca8b806da816a906faf4465bb (diff)
downloadbuildroot-novena-186ef9f6f4647ed34b67a3427a5e0e249f0794e7.tar.gz
buildroot-novena-186ef9f6f4647ed34b67a3427a5e0e249f0794e7.zip
qt5base: support static library building
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/qt5base.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index d22ab66f3..0d0fb1177 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -37,6 +37,14 @@ else
QT5BASE_CONFIGURE_OPTS += -release
endif
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+QT5BASE_CONFIGURE_OPTS += -static
+else
+# We apparently can't build both the shared and static variants of the
+# library.
+QT5BASE_CONFIGURE_OPTS += -shared
+endif
+
ifeq ($(BR2_LARGEFILE),y)
QT5BASE_CONFIGURE_OPTS += -largefile
else
@@ -179,10 +187,16 @@ define QT5BASE_INSTALL_TARGET_FONTS
fi
endef
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+define QT5BASE_INSTALL_TARGET_CMDS
+ $(QT5BASE_INSTALL_TARGET_FONTS)
+endef
+else
define QT5BASE_INSTALL_TARGET_CMDS
$(QT5BASE_INSTALL_TARGET_LIBS)
$(QT5BASE_INSTALL_TARGET_PLUGINS)
$(QT5BASE_INSTALL_TARGET_FONTS)
endef
+endif
$(eval $(generic-package))