summaryrefslogtreecommitdiffstats
path: root/package/qt/qt.mk
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2010-07-21 23:20:59 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-26 22:52:50 +0200
commitcf75bd278968a7dca0d01dcd3f5885cbe3c74d39 (patch)
tree5568e81a8ac11a313c4d65c621552274dc4863ba /package/qt/qt.mk
parentf978f2249d2c420a3e4eb5bd804ca524380f1ae2 (diff)
downloadbuildroot-novena-cf75bd278968a7dca0d01dcd3f5885cbe3c74d39.tar.gz
buildroot-novena-cf75bd278968a7dca0d01dcd3f5885cbe3c74d39.zip
qt: fix alsa-lib dependency
If BR2_PACKAGE_QT_AUDIO_BACKEND=y, QtMultimedia requires the audio backend to be already in staging in order to compile. The backend is system-dependent, but since buildroot builds Linux systems only, it is safe to assume that the it will always be ALSA. Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt/qt.mk')
-rw-r--r--package/qt/qt.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 864e79bb6..baf653991 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -312,6 +312,7 @@ endif
ifeq ($(BR2_PACKAGE_QT_AUDIO_BACKEND),y)
QT_CONFIGURE+= -audio-backend
+QT_DEP_LIBS+=alsa-lib
else
QT_CONFIGURE+= -no-audio-backend
endif