summaryrefslogtreecommitdiffstats
path: root/package/qextserialport
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-06-02 18:13:55 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-03 18:35:40 +0100
commit7eca96e65f750e40d5cb558acf45b906bb6453e6 (patch)
tree146d370a51878582797c5bc380bd8fc93482842e /package/qextserialport
parent51f3425e3d6c69758c071b9327eecaa14b5e053a (diff)
downloadbuildroot-novena-7eca96e65f750e40d5cb558acf45b906bb6453e6.tar.gz
buildroot-novena-7eca96e65f750e40d5cb558acf45b906bb6453e6.zip
qextserialport: new package
[Peter: adjust for BR changes] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qextserialport')
-rw-r--r--package/qextserialport/Config.in9
-rw-r--r--package/qextserialport/qextserialport-main-include.patch15
-rw-r--r--package/qextserialport/qextserialport-no-examples.patch17
-rw-r--r--package/qextserialport/qextserialport-pkgconfig.patch19
-rw-r--r--package/qextserialport/qextserialport.mk35
5 files changed, 95 insertions, 0 deletions
diff --git a/package/qextserialport/Config.in b/package/qextserialport/Config.in
new file mode 100644
index 000000000..4e92ecf3b
--- /dev/null
+++ b/package/qextserialport/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_QEXTSERIALPORT
+ bool "qextserialport"
+ # Qt is a big library, we don't want to select it
+ # automatically without the user knowing
+ depends on BR2_PACKAGE_QT
+ help
+ A Qt library to manage serial ports
+
+ http://code.google.com/p/qextserialport/
diff --git a/package/qextserialport/qextserialport-main-include.patch b/package/qextserialport/qextserialport-main-include.patch
new file mode 100644
index 000000000..858f3354d
--- /dev/null
+++ b/package/qextserialport/qextserialport-main-include.patch
@@ -0,0 +1,15 @@
+Create a main include file QExtSerialPort
+
+This main include file will be installed in
+<QExtSerialPort/QExtSerialPort> so that Qt applications can use this
+library by including header files in a Qt-like style.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: qextserialport-ef4af2a2ee3f/src/QExtSerialPort
+===================================================================
+--- /dev/null
++++ qextserialport-ef4af2a2ee3f/src/QExtSerialPort
+@@ -0,0 +1,2 @@
++#include "qextserialport.h"
++#include "qextserialenumerator.h"
diff --git a/package/qextserialport/qextserialport-no-examples.patch b/package/qextserialport/qextserialport-no-examples.patch
new file mode 100644
index 000000000..c7d2d41b9
--- /dev/null
+++ b/package/qextserialport/qextserialport-no-examples.patch
@@ -0,0 +1,17 @@
+Disable compilation of examples
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: qextserialport-ef4af2a2ee3f/qextserialport.pro
+===================================================================
+--- qextserialport-ef4af2a2ee3f.orig/qextserialport.pro
++++ qextserialport-ef4af2a2ee3f/qextserialport.pro
+@@ -1,7 +1,4 @@
+ #
+ TEMPLATE = subdirs
+ CONFIG += ordered
+-SUBDIRS = src \
+- examples/enumerator \
+- examples/event
+-
++SUBDIRS = src
diff --git a/package/qextserialport/qextserialport-pkgconfig.patch b/package/qextserialport/qextserialport-pkgconfig.patch
new file mode 100644
index 000000000..d67f3fcbb
--- /dev/null
+++ b/package/qextserialport/qextserialport-pkgconfig.patch
@@ -0,0 +1,19 @@
+Add a pkgconfig file to ease usage with applications
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: qextserialport-ef4af2a2ee3f/qextserialport.pc
+===================================================================
+--- /dev/null
++++ qextserialport-ef4af2a2ee3f/qextserialport.pc
+@@ -0,0 +1,10 @@
++prefix=/usr
++exec_prefix=${prefix}
++libdir=${prefix}/lib
++includedir=${prefix}/include/QExtSerialPort
++
++Name: QtExtSerialPort
++Description: QtExtSerialPort library
++Version: 1.2.0
++Libs: -L${libdir} -lqextserialport
++Cflags: -I${includedir}
diff --git a/package/qextserialport/qextserialport.mk b/package/qextserialport/qextserialport.mk
new file mode 100644
index 000000000..6ffb9ebb7
--- /dev/null
+++ b/package/qextserialport/qextserialport.mk
@@ -0,0 +1,35 @@
+#############################################################
+#
+# qextserialport
+#
+#############################################################
+
+QEXTSERIALPORT_VERSION = ef4af2a2ee3f
+QEXTSERIALPORT_SITE = https://qextserialport.googlecode.com/hg/
+QEXTSERIALPORT_SITE_METHOD = hg
+
+QEXTSERIALPORT_DEPENDENCIES = qt
+
+QEXTSERIALPORT_INSTALL_STAGING = YES
+
+define QEXTSERIALPORT_CONFIGURE_CMDS
+ (cd $(@D); $(QT_QMAKE))
+endef
+
+define QEXTSERIALPORT_BUILD_CMDS
+ $(MAKE) -C $(@D)
+endef
+
+define QEXTSERIALPORT_INSTALL_STAGING_CMDS
+ mkdir -p $(STAGING_DIR)/usr/include/QExtSerialPort
+ cp $(@D)/src/*.h $(STAGING_DIR)/usr/include/QExtSerialPort/
+ cp $(@D)/src/QExtSerialPort $(STAGING_DIR)/usr/include/QExtSerialPort/
+ cp -a $(@D)/src/build/*.so* $(STAGING_DIR)/usr/lib/
+ cp $(@D)/qextserialport.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+endef
+
+define QEXTSERIALPORT_INSTALL_TARGET_CMDS
+ cp -a $(@D)/src/build/*.so.* $(TARGET_DIR)/usr/lib
+endef
+
+$(eval $(generic-package))