summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/python
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
downloadbuildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/python')
-rw-r--r--package/python/Makefile.in3
-rw-r--r--package/python/python.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/python/Makefile.in b/package/python/Makefile.in
deleted file mode 100644
index ded82d842..000000000
--- a/package/python/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_PYTHON)),y)
-TARGETS+=python
-endif
diff --git a/package/python/python.mk b/package/python/python.mk
index 322221989..995c6aa9a 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -81,3 +81,11 @@ python-clean:
python-dirclean:
rm -rf $(PYTHON_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_PYTHON)),y)
+TARGETS+=python
+endif