summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2011-08-12 14:22:56 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-08-14 08:52:13 +0200
commitad891ac44aa826ebed7fa35be4912116255f5da6 (patch)
tree97cc349d634ad3b5f1929e243b5c4eb8f7f43f5c /package/python
parente35921b3a0d148098f08d2f0533b238a65ff3e86 (diff)
downloadbuildroot-novena-ad891ac44aa826ebed7fa35be4912116255f5da6.tar.gz
buildroot-novena-ad891ac44aa826ebed7fa35be4912116255f5da6.zip
Fix the Python build when running Linux 3.*
When compiling Python on a host running Linux 3.0, the sys.platform constant is set at "linux3". A lot of code (inside the interpreter itself, its build system and third party apps and libraries) relies on it to be linux2 on a Linux system. This leads to the build of the target python package to break. This behaviour has been reported on the Python bugtracker but is not fixed yet. http://bugs.python.org/issue12326 Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python-2.7-013-fix-linux-3-compilation.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/python/python-2.7-013-fix-linux-3-compilation.patch b/package/python/python-2.7-013-fix-linux-3-compilation.patch
new file mode 100644
index 000000000..a43ec7ee4
--- /dev/null
+++ b/package/python/python-2.7-013-fix-linux-3-compilation.patch
@@ -0,0 +1,22 @@
+diff -r 683202530137 configure
+--- a/configure Fri Aug 12 11:40:39 2011 +0300
++++ b/configure Fri Aug 12 14:02:18 2011 +0200
+@@ -3055,6 +3055,7 @@ then
+ cygwin*) MACHDEP="cygwin";;
+ darwin*) MACHDEP="darwin";;
+ irix646) MACHDEP="irix6";;
++ linux*) MACHDEP="linux2";;
+ '') MACHDEP="unknown";;
+ esac
+ fi
+diff -r 683202530137 configure.in
+--- a/configure.in Fri Aug 12 11:40:39 2011 +0300
++++ b/configure.in Fri Aug 12 14:02:18 2011 +0200
+@@ -307,6 +307,7 @@ then
+ cygwin*) MACHDEP="cygwin";;
+ darwin*) MACHDEP="darwin";;
+ irix646) MACHDEP="irix6";;
++ linux*) MACHDEP="linux2";;
+ '') MACHDEP="unknown";;
+ esac
+ fi