summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorvsergeev <vsergeev@gmail.com>2012-04-22 01:03:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-24 22:57:05 +0200
commit94c297c4488ced4f580dd036a42f6718f072e57a (patch)
tree19d21dc5f06088a04ab7fe539a61f90c2be64c7a /package/python
parent2a10c9d0a2aaec7597b53b90fff784dfc691f337 (diff)
downloadbuildroot-novena-94c297c4488ced4f580dd036a42f6718f072e57a.tar.gz
buildroot-novena-94c297c4488ced4f580dd036a42f6718f072e57a.zip
python: enable IPv6 socket support
Added patch to disable buggy_getaddrinfo test during configure when cross-compiling. [Peter: Remove --enable-ipv6 which is now handled globally] Signed-off-by: Vanya Sergeev <vsergeev at gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python-2.7-016-cross-compile-getaddrinfo.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/python/python-2.7-016-cross-compile-getaddrinfo.patch b/package/python/python-2.7-016-cross-compile-getaddrinfo.patch
new file mode 100644
index 000000000..dae300577
--- /dev/null
+++ b/package/python/python-2.7-016-cross-compile-getaddrinfo.patch
@@ -0,0 +1,15 @@
+Disable buggy_getaddrinfo configure test when cross-compiling with IPv6 support
+
+Signed-off-by: Vanya Sergeev <vsergeev at gmail.com>
+
+--- python-2.7.2.orig/configure.in 2012-04-22 06:52:09.361809545 -0400
++++ python-2.7.2/configure.in 2012-04-22 06:56:37.900634194 -0400
+@@ -3128,7 +3128,7 @@
+
+ AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
+
+-if test $have_getaddrinfo = no -o "$ac_cv_buggy_getaddrinfo" = yes
++if test $have_getaddrinfo = no || test "$cross_compiling" != "yes" -a "$ac_cv_buggy_getaddrinfo" = yes
+ then
+ if test $ipv6 = yes
+ then