summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-05-10 06:29:36 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-11 22:41:44 +0200
commit85c798b88b56dbf79caba55226e0ebf12817caf2 (patch)
tree1aeea7fd454d07f71045e9e793a77f5e622e5882 /package/python
parent4af6818109bf94ea809c0cb7f39f86527bb907d7 (diff)
downloadbuildroot-novena-85c798b88b56dbf79caba55226e0ebf12817caf2.tar.gz
buildroot-novena-85c798b88b56dbf79caba55226e0ebf12817caf2.zip
python: remove stale python2-config symbolic link
We already remove python2.7-config and the symbolic link python-config, but we forgot to remove the python2-config symbolic link. Note that we can't use the <pkg>_CONFIG_SCRIPTS mechanism here because python2.7-config is written in... Python, and doesn't follow the usual syntax of <pkg>-config scripts. It takes the paths directly from distutils.sysconfig. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index b94285499..801c6692d 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -154,6 +154,7 @@ PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_REMOVE_SMTPD
#
define PYTHON_REMOVE_DEVFILES
rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON_VERSION_MAJOR)-config
+ rm -f $(TARGET_DIR)/usr/bin/python2-config
rm -f $(TARGET_DIR)/usr/bin/python-config
endef