summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-27 23:37:22 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-27 23:37:22 +0100
commit5a7192b25349e3e046ccadc1926062ffbf69cc9f (patch)
treef7d63a3ce1b2e9a36a199a12b55de73d6ffc53bf /package/python
parentf13d97e106d115e00b1ca4e9009baaf0de43cd85 (diff)
downloadbuildroot-novena-5a7192b25349e3e046ccadc1926062ffbf69cc9f.tar.gz
buildroot-novena-5a7192b25349e3e046ccadc1926062ffbf69cc9f.zip
host-python: enable expat support
Some packages (like libxcb) need xml support in host-python in order to build (.py file tries to import xml.etree.cElementTree). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 4b80538f9..c2839b735 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -18,7 +18,7 @@ HOST_PYTHON_CONF_OPT += \
--without-cxx-main \
--disable-sqlite3 \
--disable-tk \
- --with-expat=none \
+ --with-expat=system \
--disable-curses \
--disable-codecs-cjk \
--disable-nis \
@@ -39,6 +39,8 @@ HOST_PYTHON_AUTORECONF = YES
PYTHON_DEPENDENCIES = host-python libffi
+HOST_PYTHON_DEPENDENCIES = host-expat
+
PYTHON_INSTALL_STAGING = YES
ifeq ($(BR2_PACKAGE_PYTHON_READLINE),y)