summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2011-08-29 17:56:44 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-08-29 22:44:53 +0200
commit3c90f754961c6d99059c0b6d0a66bc797a3c017b (patch)
treed57bfb0b7cbb4843e98d0d7404c6da4e22cd571b /package/python
parent68c344a372177bf6c1d59c593c384b799f51fdeb (diff)
downloadbuildroot-novena-3c90f754961c6d99059c0b6d0a66bc797a3c017b.tar.gz
buildroot-novena-3c90f754961c6d99059c0b6d0a66bc797a3c017b.zip
Fix regression in Python build on 64 bits system
Commit 009d8fceab4db7815502e4b0565fe0ef531d512c introduced --enable-shared --disable-static options for the host autotools packages, ultimately causing a regression on the host-python build, leading to a number of critical modules not being built on the target python on 64 bits system. Introduce a quick fix for the release and before a deeper fix. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index c2839b735..724fd1a92 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -37,6 +37,19 @@ HOST_PYTHON_MAKE_ENV = \
HOST_PYTHON_AUTORECONF = YES
+define HOST_PYTHON_CONFIGURE_CMDS
+ (cd $(@D) && rm -rf config.cache; \
+ $(HOST_CONFIGURE_OPTS) \
+ CFLAGS="$(HOST_CFLAGS)" \
+ LDFLAGS="$(HOST_LDFLAGS)" \
+ $(HOST_PYTHON_CONF_ENV) \
+ ./configure \
+ --prefix="$(HOST_DIR)/usr" \
+ --sysconfdir="$(HOST_DIR)/etc" \
+ $(HOST_PYTHON_CONF_OPT) \
+ )
+endef
+
PYTHON_DEPENDENCIES = host-python libffi
HOST_PYTHON_DEPENDENCIES = host-expat