summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorHamish Moffatt <hamish@cloud.net.au>2008-09-02 00:54:49 +0000
committerHamish Moffatt <hamish@cloud.net.au>2008-09-02 00:54:49 +0000
commit0fbc9437e0aab4289dd0ed9846bdaceb3f06f040 (patch)
tree4d72c610e9830e7bd6909b185ec4827385aeecbd /package/python
parent4b5f12fb5b3db2a8d57215bc8b6dec8f413cd9fe (diff)
downloadbuildroot-novena-0fbc9437e0aab4289dd0ed9846bdaceb3f06f040.tar.gz
buildroot-novena-0fbc9437e0aab4289dd0ed9846bdaceb3f06f040.zip
Update to Python 2.4.5 (latest patch rev of 2.4)
Remove the test suite before building, else it will fail to compile depending on what modules have been configured.
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 53d59c812..919c932ac 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -3,7 +3,7 @@
# python
#
#############################################################
-PYTHON_VERSION=2.4.2
+PYTHON_VERSION=2.4.5
PYTHON_VERSION_SHORT=2.4
PYTHON_SOURCE:=Python-$(PYTHON_VERSION).tar.bz2
PYTHON_SITE:=http://python.org/ftp/python/$(PYTHON_VERSION)
@@ -124,6 +124,7 @@ $(TARGET_DIR)/$(PYTHON_TARGET_BINARY): $(PYTHON_DIR)/$(PYTHON_BINARY)
ifneq ($(BR2_PACKAGE_PYTHON_SSL),y)
export PYTHON_DISABLE_SSL=1
endif
+ rm -rf $(PYTHON_DIR)/Lib/test
LD_LIBRARY_PATH=$(STAGING_DIR)/lib
$(MAKE) CC=$(TARGET_CC) -C $(PYTHON_DIR) install \
DESTDIR=$(TARGET_DIR) CROSS_COMPILE=yes \