summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-05-06 01:55:42 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-06 13:58:38 +0200
commit0d2fbe9d75308571da3afc2a5d1f3586c0ca3bec (patch)
tree750d49531c6db4dc11faa6b7340aba83e4b40077 /package/python
parent9ae2f2c2853e8268254a816789c3888173617965 (diff)
downloadbuildroot-novena-0d2fbe9d75308571da3afc2a5d1f3586c0ca3bec.tar.gz
buildroot-novena-0d2fbe9d75308571da3afc2a5d1f3586c0ca3bec.zip
python: remove smtpd.py
It's mostly sample code, normally not used, and has a bad shebang line. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 4876dd8b5..b94285499 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -142,6 +142,13 @@ endef
PYTHON_POST_INSTALL_STAGING_HOOKS += PYTHON_FIXUP_LIBDIR
+# Bad shebang, normally not used
+define PYTHON_REMOVE_SMTPD
+ rm -f $(TARGET_DIR)/usr/bin/smtpd.py
+endef
+
+PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_REMOVE_SMTPD
+
#
# Development files removal
#