summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorWill Newton <will.newton@gmail.com>2009-09-17 17:45:11 +0100
committerWill Newton <will.newton@gmail.com>2009-09-20 19:34:48 +0100
commit0c2b9a4a2df1d42ab8ebfaf340bbfeeed1268c48 (patch)
tree1aa7d884730875594e1c08f366b9d8af37900128 /package/python
parent1a9015f5d557c594f6719ea08e6c629a1f4c0398 (diff)
downloadbuildroot-novena-0c2b9a4a2df1d42ab8ebfaf340bbfeeed1268c48.tar.gz
buildroot-novena-0c2b9a4a2df1d42ab8ebfaf340bbfeeed1268c48.zip
python: Don't delete .py files unless asked.
If we have set BR2_PACKAGE_PYTHON_PY_ONLY or BR2_PACKAGE_PYTHON_PY_PYC we want .py files to be left on the target, whatever the value of BR2_PACKAGE_PYTHON_DEV. Signed-off-by: Will Newton <will.newton@gmail.com>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index cd1ccece3..95586ad64 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -155,7 +155,6 @@ endif
ifneq ($(BR2_PACKAGE_PYTHON_DEV),y)
rm -rf $(TARGET_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
rm -rf $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/config
- find $(TARGET_DIR)/usr/lib/ -name '*.py' -exec rm {} \;
endif
ifneq ($(BR2_PACKAGE_PYTHON_BSDDB),y)
rm -rf $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/bsddb