summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@anandra.org>2010-12-14 23:02:22 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-01-25 08:56:20 +0100
commit05ac95e04d0b9867194492f75f4713498e2ab7df (patch)
treedad13a8251216c7547fc2b15f7a3254de5ed555c /package/python
parent10e1927e1a1bc21785b9482fc4ba70d3b4773854 (diff)
downloadbuildroot-novena-05ac95e04d0b9867194492f75f4713498e2ab7df.tar.gz
buildroot-novena-05ac95e04d0b9867194492f75f4713498e2ab7df.zip
python: Fix make install (Workaround python's bug #1669349)
Signed-off-by: Maxime Ripard <ripard@archos.com>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 5c85c5946..3afc1326d 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -128,7 +128,15 @@ ifneq ($(BR2_PACKAGE_PYTHON_SSL),y)
endif
rm -rf $(PYTHON_DIR)/Lib/test
LD_LIBRARY_PATH=$(STAGING_DIR)/lib
- $(MAKE) CC="$(TARGET_CC)" -C $(PYTHON_DIR) install \
+ # FIXME: The make -i just below is to work around python's bug
+ # #1669349 (http://bugs.python.org/issue1669349) which is introducing
+ # a failure at make install on a python-free system. Since none of
+ # the other the provided workaround work, the make -i is the only
+ # solution. The failing lib is install later in the process, so
+ # even if the compilation is failing without the patch, with it, the
+ # target python is fully functionnal.
+ # The "-i" will have to be removed when the bug will be solved.
+ $(MAKE) CC="$(TARGET_CC)" -C $(PYTHON_DIR) -i install \
DESTDIR=$(TARGET_DIR) CROSS_COMPILE=yes \
PYTHON_MODULES_INCLUDE=$(STAGING_DIR)/usr/include \
PYTHON_MODULES_LIB="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \