summaryrefslogtreecommitdiffstats
path: root/package/python3
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-06-30 21:29:08 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-04 09:06:33 +0200
commit12d1aa4b69614f6499847758294f8a40f1611710 (patch)
tree58c1d6e648a149cb40cc88a5727fdee0cb292244 /package/python3
parente57e4b96bf33b5a498608204913d6731a6856b5e (diff)
downloadbuildroot-novena-12d1aa4b69614f6499847758294f8a40f1611710.tar.gz
buildroot-novena-12d1aa4b69614f6499847758294f8a40f1611710.zip
Remove BR2_HAVE_DEVFILES
This finally removes the BR2_HAVE_DEVFILES option, that was used to install/keep development files on target. With the recent migration of the internal backend to the package infrastructure, we had anyway lost the ability to build gcc for the target, and install the uClibc development files on the target. [Peter: also remove support/scripts/copy.sh] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python3')
-rw-r--r--package/python3/python3.mk16
1 files changed, 3 insertions, 13 deletions
diff --git a/package/python3/python3.mk b/package/python3/python3.mk
index 39202ff1b..ed79f8e3e 100644
--- a/package/python3/python3.mk
+++ b/package/python3/python3.mk
@@ -134,23 +134,13 @@ endef
PYTHON3_POST_INSTALL_STAGING_HOOKS += PYTHON3_FIXUP_LIBDIR
#
-# Development files removal
-#
-define PYTHON3_REMOVE_DEVFILES
- rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON3_VERSION_MAJOR)-config
- rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON3_VERSION_MAJOR)m-config
- rm -f $(TARGET_DIR)/usr/bin/python3-config
-endef
-
-ifneq ($(BR2_HAVE_DEVFILES),y)
-PYTHON3_POST_INSTALL_TARGET_HOOKS += PYTHON3_REMOVE_DEVFILES
-endif
-
-#
# Remove useless files. In the config/ directory, only the Makefile
# and the pyconfig.h files are needed at runtime.
#
define PYTHON3_REMOVE_USELESS_FILES
+ rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON3_VERSION_MAJOR)-config
+ rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON3_VERSION_MAJOR)m-config
+ rm -f $(TARGET_DIR)/usr/bin/python3-config
for i in `find $(TARGET_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/config-3.3m/ \
-type f -not -name pyconfig.h -a -not -name Makefile` ; do \
rm -f $$i ; \