summaryrefslogtreecommitdiffstats
path: root/package/python3/python3-3.3-003-staging-header-libs.patch
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2012-11-07 05:01:21 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-08 00:10:23 +0100
commit03c4d57f1d9e2b0f516afdd7e7b3f082694d3c0a (patch)
tree6468647d08879169eaaf2bd2d61c64471f905b5a /package/python3/python3-3.3-003-staging-header-libs.patch
parenta32fa707e5d79c92908bb81142b00afe81a3e3e2 (diff)
downloadbuildroot-novena-03c4d57f1d9e2b0f516afdd7e7b3f082694d3c0a.tar.gz
buildroot-novena-03c4d57f1d9e2b0f516afdd7e7b3f082694d3c0a.zip
Add python3 package
[Peter: s/python/python3/] Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python3/python3-3.3-003-staging-header-libs.patch')
-rw-r--r--package/python3/python3-3.3-003-staging-header-libs.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/package/python3/python3-3.3-003-staging-header-libs.patch b/package/python3/python3-3.3-003-staging-header-libs.patch
new file mode 100644
index 000000000..b0efe2961
--- /dev/null
+++ b/package/python3/python3-3.3-003-staging-header-libs.patch
@@ -0,0 +1,41 @@
+Tell setup.py the location of headers/libraries
+
+Allow the libraries detection routine to look for headers and libs in
+other directories than /usr/include or /usr/lib through the
+environment variables PYTHON_MODULES_INCLUDE and PYTHON_MODULES_LIB.
+
+We can then use it to look for libraries in the buildroot staging
+directory.
+
+Ported to python3.3 by Maxime Ripard <maxime.ripard@free-electrons.com> based
+on the work by Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
+---
+ setup.py | 13 +++++++++++++
+ 1 file changed, 13 insertions(+)
+
+Index: Python-3.3.0/setup.py
+===================================================================
+--- Python-3.3.0.orig/setup.py
++++ Python-3.3.0/setup.py
+@@ -441,6 +441,19 @@
+ os.unlink(tmpfile)
+
+ def detect_modules(self):
++ try:
++ modules_include_dirs = os.environ["PYTHON_MODULES_INCLUDE"].split()
++ except KeyError:
++ modules_include_dirs = ['/usr/include']
++ try:
++ modules_lib_dirs = os.environ["PYTHON_MODULES_LIB"].split()
++ except KeyError:
++ modules_lib_dirs = ['/usr/lib']
++ for dir in modules_include_dirs:
++ add_dir_to_list(self.compiler.include_dirs, dir)
++ for dir in modules_lib_dirs:
++ add_dir_to_list(self.compiler.library_dirs, dir)
++
+ # Ensure that /usr/local is always used, but the local build
+ # directories (i.e. '.' and 'Include') must be first. See issue
+ # 10520.