summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-102-optional-2to3.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-18 18:05:23 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-18 21:05:10 +0200
commit2455c89bab315c0b6842198f16777585029e364f (patch)
tree721daabcba459ded2c463c31a7a118a358c29fc4 /package/python/python-2.7-102-optional-2to3.patch
parenta21642c7eb06eeffe621e7eaef1a85cb9b4589f8 (diff)
downloadbuildroot-novena-2455c89bab315c0b6842198f16777585029e364f.tar.gz
buildroot-novena-2455c89bab315c0b6842198f16777585029e364f.zip
python: bump to 2.7.2
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python/python-2.7-102-optional-2to3.patch')
-rw-r--r--package/python/python-2.7-102-optional-2to3.patch55
1 files changed, 25 insertions, 30 deletions
diff --git a/package/python/python-2.7-102-optional-2to3.patch b/package/python/python-2.7-102-optional-2to3.patch
index 3550db132..1e0454065 100644
--- a/package/python/python-2.7-102-optional-2to3.patch
+++ b/package/python/python-2.7-102-optional-2to3.patch
@@ -11,34 +11,29 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
setup.py | 5 +++--
3 files changed, 26 insertions(+), 9 deletions(-)
-Index: Python-2.7.1/Makefile.pre.in
+Index: Python-2.7.2/Makefile.pre.in
===================================================================
---- Python-2.7.1.orig/Makefile.pre.in
-+++ Python-2.7.1/Makefile.pre.in
-@@ -856,9 +856,7 @@
- encodings compiler hotshot \
- email email/mime \
+--- Python-2.7.2.orig/Makefile.pre.in
++++ Python-2.7.2/Makefile.pre.in
+@@ -862,7 +862,6 @@
json \
-- sqlite3 \
+ sqlite3 \
logging bsddb csv importlib wsgiref \
- lib2to3 lib2to3/fixes lib2to3/pgen2 \
- ctypes ctypes/macholib idlelib idlelib/Icons \
- distutils distutils/command $(XMLLIBSUBDIRS) \
+ ctypes ctypes/macholib idlelib idlelib/Icons \
+ distutils distutils/command $(XMLLIBSUBDIRS) \
multiprocessing multiprocessing/dummy \
-@@ -872,12 +870,7 @@
- test/decimaltestdata test/xmltestdata \
- test/tracedmodules \
- email/test email/test/data \
-- sqlite3/test \
- bsddb/test \
-- lib2to3/tests \
-- lib2to3/tests/data \
-- lib2to3/tests/data/fixers \
-- lib2to3/tests/data/fixers/myfixes \
- ctypes/test distutils/tests \
- unittest/test
+@@ -875,8 +874,7 @@
+ lib-tk/test/test_ttk test test/data \
+ test/cjkencodings test/decimaltestdata test/xmltestdata test/subprocessdata \
+ test/tracedmodules email/test email/test/data \
+- json/tests sqlite3/test bsddb/test lib2to3/tests \
+- lib2to3/tests/data lib2to3/tests/data/fixers lib2to3/tests/data/fixers/myfixes \
++ json/tests sqlite3/test bsddb/test \
+ ctypes/test distutils/tests unittest/test
endif
-@@ -886,6 +879,23 @@
+
+@@ -884,6 +882,23 @@
LIBSUBDIRS += pydoc_data
endif
@@ -62,11 +57,11 @@ Index: Python-2.7.1/Makefile.pre.in
libinstall: build_all $(srcdir)/Lib/$(PLATDIR)
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
-Index: Python-2.7.1/configure.in
+Index: Python-2.7.2/configure.in
===================================================================
---- Python-2.7.1.orig/configure.in
-+++ Python-2.7.1/configure.in
-@@ -2404,6 +2404,12 @@
+--- Python-2.7.2.orig/configure.in
++++ Python-2.7.2/configure.in
+@@ -2419,6 +2419,12 @@
AS_HELP_STRING([--disable-test-modules], [disable test modules]),
[ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
@@ -79,11 +74,11 @@ Index: Python-2.7.1/configure.in
# Check for enable-ipv6
AH_TEMPLATE(ENABLE_IPV6, [Define if --enable-ipv6 is specified])
AC_MSG_CHECKING([if --enable-ipv6 is specified])
-Index: Python-2.7.1/setup.py
+Index: Python-2.7.2/setup.py
===================================================================
---- Python-2.7.1.orig/setup.py
-+++ Python-2.7.1/setup.py
-@@ -2073,10 +2073,11 @@
+--- Python-2.7.2.orig/setup.py
++++ Python-2.7.2/setup.py
+@@ -2093,10 +2093,11 @@
import warnings
warnings.filterwarnings("ignore",category=DeprecationWarning)