summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-101-optional-pydoc.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-18 18:05:23 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-18 21:05:10 +0200
commit2455c89bab315c0b6842198f16777585029e364f (patch)
tree721daabcba459ded2c463c31a7a118a358c29fc4 /package/python/python-2.7-101-optional-pydoc.patch
parenta21642c7eb06eeffe621e7eaef1a85cb9b4589f8 (diff)
downloadbuildroot-novena-2455c89bab315c0b6842198f16777585029e364f.tar.gz
buildroot-novena-2455c89bab315c0b6842198f16777585029e364f.zip
python: bump to 2.7.2
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python/python-2.7-101-optional-pydoc.patch')
-rw-r--r--package/python/python-2.7-101-optional-pydoc.patch32
1 files changed, 16 insertions, 16 deletions
diff --git a/package/python/python-2.7-101-optional-pydoc.patch b/package/python/python-2.7-101-optional-pydoc.patch
index 8d51dc95b..195abcc6e 100644
--- a/package/python/python-2.7-101-optional-pydoc.patch
+++ b/package/python/python-2.7-101-optional-pydoc.patch
@@ -11,11 +11,11 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
setup.py | 10 +++++++---
3 files changed, 17 insertions(+), 4 deletions(-)
-Index: Python-2.7.1/Makefile.pre.in
+Index: Python-2.7.2/Makefile.pre.in
===================================================================
---- Python-2.7.1.orig/Makefile.pre.in
-+++ Python-2.7.1/Makefile.pre.in
-@@ -864,7 +864,7 @@
+--- Python-2.7.2.orig/Makefile.pre.in
++++ Python-2.7.2/Makefile.pre.in
+@@ -868,7 +868,7 @@
multiprocessing multiprocessing/dummy \
unittest \
lib-old \
@@ -23,9 +23,9 @@ Index: Python-2.7.1/Makefile.pre.in
+ curses $(MACHDEPS)
ifeq (@TEST_MODULES@,yes)
- LIBSUBDIRS += lib-tk/test lib-tk/test/test_tkinter \
-@@ -882,6 +882,10 @@
- unittest/test
+ LIBSUBDIRS += lib-tk/test lib-tk/test/test_tkinter \
+@@ -880,6 +880,10 @@
+ ctypes/test distutils/tests unittest/test
endif
+ifeq (@PYDOC@,yes)
@@ -35,11 +35,11 @@ Index: Python-2.7.1/Makefile.pre.in
libinstall: build_all $(srcdir)/Lib/$(PLATDIR)
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
-Index: Python-2.7.1/configure.in
+Index: Python-2.7.2/configure.in
===================================================================
---- Python-2.7.1.orig/configure.in
-+++ Python-2.7.1/configure.in
-@@ -2392,6 +2392,11 @@
+--- Python-2.7.2.orig/configure.in
++++ Python-2.7.2/configure.in
+@@ -2407,6 +2407,11 @@
esac])
fi
@@ -51,11 +51,11 @@ Index: Python-2.7.1/configure.in
AC_SUBST(TEST_MODULES)
-Index: Python-2.7.1/setup.py
+Index: Python-2.7.2/setup.py
===================================================================
---- Python-2.7.1.orig/setup.py
-+++ Python-2.7.1/setup.py
-@@ -2072,6 +2072,12 @@
+--- Python-2.7.2.orig/setup.py
++++ Python-2.7.2/setup.py
+@@ -2092,6 +2092,12 @@
# turn off warnings when deprecated modules are imported
import warnings
warnings.filterwarnings("ignore",category=DeprecationWarning)
@@ -68,7 +68,7 @@ Index: Python-2.7.1/setup.py
setup(# PyPI Metadata (PEP 301)
name = "Python",
version = sys.version.split()[0],
-@@ -2092,9 +2098,7 @@
+@@ -2112,9 +2118,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install