summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-100-optional-test-modules.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-18 18:05:23 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-18 21:05:10 +0200
commit2455c89bab315c0b6842198f16777585029e364f (patch)
tree721daabcba459ded2c463c31a7a118a358c29fc4 /package/python/python-2.7-100-optional-test-modules.patch
parenta21642c7eb06eeffe621e7eaef1a85cb9b4589f8 (diff)
downloadbuildroot-novena-2455c89bab315c0b6842198f16777585029e364f.tar.gz
buildroot-novena-2455c89bab315c0b6842198f16777585029e364f.zip
python: bump to 2.7.2
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python/python-2.7-100-optional-test-modules.patch')
-rw-r--r--package/python/python-2.7-100-optional-test-modules.patch47
1 files changed, 20 insertions, 27 deletions
diff --git a/package/python/python-2.7-100-optional-test-modules.patch b/package/python/python-2.7-100-optional-test-modules.patch
index b51ea57cc..fc49d5219 100644
--- a/package/python/python-2.7-100-optional-test-modules.patch
+++ b/package/python/python-2.7-100-optional-test-modules.patch
@@ -10,20 +10,19 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
configure.in | 6 ++++++
2 files changed, 33 insertions(+), 13 deletions(-)
-Index: Python-2.7.1/Makefile.pre.in
+Index: Python-2.7.2/Makefile.pre.in
===================================================================
---- Python-2.7.1.orig/Makefile.pre.in
-+++ Python-2.7.1/Makefile.pre.in
-@@ -851,23 +851,37 @@
+--- Python-2.7.2.orig/Makefile.pre.in
++++ Python-2.7.2/Makefile.pre.in
+@@ -856,23 +856,30 @@
plat-mac/lib-scriptpackages/SystemEvents \
plat-mac/lib-scriptpackages/Terminal
PLATMACPATH=:plat-mac:plat-mac/lib-scriptpackages
-LIBSUBDIRS= lib-tk lib-tk/test lib-tk/test/test_tkinter \
-- lib-tk/test/test_ttk site-packages test test/data \
-- test/decimaltestdata test/xmltestdata \
+- lib-tk/test/test_ttk site-packages test test/data \
+- test/cjkencodings test/decimaltestdata test/xmltestdata test/subprocessdata \
- test/tracedmodules \
-+LIBSUBDIRS= lib-tk \
-+ site-packages \
++LIBSUBDIRS= lib-tk site-packages \
encodings compiler hotshot \
- email email/mime email/test email/test/data \
- json json/tests \
@@ -38,8 +37,8 @@ Index: Python-2.7.1/Makefile.pre.in
+ sqlite3 \
+ logging bsddb csv importlib wsgiref \
+ lib2to3 lib2to3/fixes lib2to3/pgen2 \
-+ ctypes ctypes/macholib idlelib idlelib/Icons \
-+ distutils distutils/command $(XMLLIBSUBDIRS) \
++ ctypes ctypes/macholib idlelib idlelib/Icons \
++ distutils distutils/command $(XMLLIBSUBDIRS) \
multiprocessing multiprocessing/dummy \
- unittest unittest/test \
+ unittest \
@@ -47,29 +46,23 @@ Index: Python-2.7.1/Makefile.pre.in
curses pydoc_data $(MACHDEPS)
+
+ifeq (@TEST_MODULES@,yes)
-+LIBSUBDIRS += lib-tk/test lib-tk/test/test_tkinter \
-+ lib-tk/test/test_ttk test test/data \
-+ test/decimaltestdata test/xmltestdata \
-+ test/tracedmodules \
-+ email/test email/test/data \
-+ sqlite3/test \
-+ bsddb/test \
-+ lib2to3/tests \
-+ lib2to3/tests/data \
-+ lib2to3/tests/data/fixers \
-+ lib2to3/tests/data/fixers/myfixes \
-+ ctypes/test distutils/tests \
-+ unittest/test
++LIBSUBDIRS += lib-tk/test lib-tk/test/test_tkinter \
++ lib-tk/test/test_ttk test test/data \
++ test/cjkencodings test/decimaltestdata test/xmltestdata test/subprocessdata \
++ test/tracedmodules email/test email/test/data \
++ json/tests sqlite3/test bsddb/test lib2to3/tests \
++ lib2to3/tests/data lib2to3/tests/data/fixers lib2to3/tests/data/fixers/myfixes \
++ ctypes/test distutils/tests unittest/test
+endif
+
libinstall: build_all $(srcdir)/Lib/$(PLATDIR)
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
-Index: Python-2.7.1/configure.in
+Index: Python-2.7.2/configure.in
===================================================================
---- Python-2.7.1.orig/configure.in
-+++ Python-2.7.1/configure.in
-@@ -2393,6 +2393,12 @@
+--- Python-2.7.2.orig/configure.in
++++ Python-2.7.2/configure.in
+@@ -2408,6 +2408,12 @@
fi