summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-008-reread-environment.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-18 18:05:23 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-18 21:05:10 +0200
commit2455c89bab315c0b6842198f16777585029e364f (patch)
tree721daabcba459ded2c463c31a7a118a358c29fc4 /package/python/python-2.7-008-reread-environment.patch
parenta21642c7eb06eeffe621e7eaef1a85cb9b4589f8 (diff)
downloadbuildroot-novena-2455c89bab315c0b6842198f16777585029e364f.tar.gz
buildroot-novena-2455c89bab315c0b6842198f16777585029e364f.zip
python: bump to 2.7.2
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python/python-2.7-008-reread-environment.patch')
-rw-r--r--package/python/python-2.7-008-reread-environment.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/package/python/python-2.7-008-reread-environment.patch b/package/python/python-2.7-008-reread-environment.patch
index e36d0cf11..4ca22a4c9 100644
--- a/package/python/python-2.7-008-reread-environment.patch
+++ b/package/python/python-2.7-008-reread-environment.patch
@@ -25,11 +25,11 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
setup.py | 3 +++
2 files changed, 6 insertions(+), 3 deletions(-)
-Index: Python-2.7.1/Makefile.pre.in
+Index: Python-2.7.2/Makefile.pre.in
===================================================================
---- Python-2.7.1.orig/Makefile.pre.in
-+++ Python-2.7.1/Makefile.pre.in
-@@ -408,8 +408,8 @@
+--- Python-2.7.2.orig/Makefile.pre.in
++++ Python-2.7.2/Makefile.pre.in
+@@ -411,8 +411,8 @@
# Build the shared modules
sharedmods: $(BUILDPYTHON)
@case $$MAKEFLAGS in \
@@ -40,7 +40,7 @@ Index: Python-2.7.1/Makefile.pre.in
esac
# Build static library
-@@ -1039,7 +1039,7 @@
+@@ -1044,7 +1044,7 @@
# Install the dynamically loadable modules
# This goes into $(exec_prefix)
sharedinstall: sharedmods
@@ -49,10 +49,10 @@ Index: Python-2.7.1/Makefile.pre.in
--prefix=$(prefix) \
--install-scripts=$(BINDIR) \
--install-platlib=$(DESTSHARED) \
-Index: Python-2.7.1/setup.py
+Index: Python-2.7.2/setup.py
===================================================================
---- Python-2.7.1.orig/setup.py
-+++ Python-2.7.1/setup.py
+--- Python-2.7.2.orig/setup.py
++++ Python-2.7.2/setup.py
@@ -20,6 +20,9 @@
# Were we compiled --with-pydebug or with #define Py_DEBUG?
COMPILED_WITH_PYDEBUG = hasattr(sys, 'gettotalrefcount')