summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-006-disable-extensions.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-18 18:05:23 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-18 21:05:10 +0200
commit2455c89bab315c0b6842198f16777585029e364f (patch)
tree721daabcba459ded2c463c31a7a118a358c29fc4 /package/python/python-2.7-006-disable-extensions.patch
parenta21642c7eb06eeffe621e7eaef1a85cb9b4589f8 (diff)
downloadbuildroot-novena-2455c89bab315c0b6842198f16777585029e364f.tar.gz
buildroot-novena-2455c89bab315c0b6842198f16777585029e364f.zip
python: bump to 2.7.2
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python/python-2.7-006-disable-extensions.patch')
-rw-r--r--package/python/python-2.7-006-disable-extensions.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/package/python/python-2.7-006-disable-extensions.patch b/package/python/python-2.7-006-disable-extensions.patch
index 642ebc585..f62a50fb5 100644
--- a/package/python/python-2.7-006-disable-extensions.patch
+++ b/package/python/python-2.7-006-disable-extensions.patch
@@ -38,11 +38,11 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
setup.py | 5 ++++-
3 files changed, 11 insertions(+), 4 deletions(-)
-Index: Python-2.7.1/Makefile.pre.in
+Index: Python-2.7.2/Makefile.pre.in
===================================================================
---- Python-2.7.1.orig/Makefile.pre.in
-+++ Python-2.7.1/Makefile.pre.in
-@@ -141,6 +141,8 @@
+--- Python-2.7.2.orig/Makefile.pre.in
++++ Python-2.7.2/Makefile.pre.in
+@@ -144,6 +144,8 @@
# configure script arguments
CONFIG_ARGS= @CONFIG_ARGS@
@@ -51,7 +51,7 @@ Index: Python-2.7.1/Makefile.pre.in
# Subdirectories with code
SRCDIRS= @SRCDIRS@
-@@ -406,8 +408,8 @@
+@@ -409,8 +411,8 @@
# Build the shared modules
sharedmods: $(BUILDPYTHON)
@case $$MAKEFLAGS in \
@@ -62,7 +62,7 @@ Index: Python-2.7.1/Makefile.pre.in
esac
# Build static library
-@@ -1046,7 +1048,7 @@
+@@ -1051,7 +1053,7 @@
# Install the dynamically loadable modules
# This goes into $(exec_prefix)
sharedinstall: sharedmods
@@ -71,11 +71,11 @@ Index: Python-2.7.1/Makefile.pre.in
--prefix=$(prefix) \
--install-scripts=$(BINDIR) \
--install-platlib=$(DESTSHARED) \
-Index: Python-2.7.1/configure.in
+Index: Python-2.7.2/configure.in
===================================================================
---- Python-2.7.1.orig/configure.in
-+++ Python-2.7.1/configure.in
-@@ -2084,6 +2084,8 @@
+--- Python-2.7.2.orig/configure.in
++++ Python-2.7.2/configure.in
+@@ -2098,6 +2098,8 @@
AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
@@ -84,10 +84,10 @@ Index: Python-2.7.1/configure.in
# Check for use of the system expat library
AC_MSG_CHECKING(for --with-system-expat)
AC_ARG_WITH(system_expat,
-Index: Python-2.7.1/setup.py
+Index: Python-2.7.2/setup.py
===================================================================
---- Python-2.7.1.orig/setup.py
-+++ Python-2.7.1/setup.py
+--- Python-2.7.2.orig/setup.py
++++ Python-2.7.2/setup.py
@@ -21,7 +21,10 @@
COMPILED_WITH_PYDEBUG = hasattr(sys, 'gettotalrefcount')