summaryrefslogtreecommitdiffstats
path: root/package/python-setuptools
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2012-01-04 12:30:03 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-07 20:57:37 +0100
commit0717f0357db48198a01233b0629251ba5399ca27 (patch)
treef846b7ce2c99b8f189ad81e0d23c355948908e37 /package/python-setuptools
parentbdd274110a160ec67fceae642d14a5c3f77a87aa (diff)
downloadbuildroot-novena-0717f0357db48198a01233b0629251ba5399ca27.tar.gz
buildroot-novena-0717f0357db48198a01233b0629251ba5399ca27.zip
New package: python-setuptools
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python-setuptools')
-rw-r--r--package/python-setuptools/Config.in8
-rw-r--r--package/python-setuptools/python-setuptools.mk34
2 files changed, 42 insertions, 0 deletions
diff --git a/package/python-setuptools/Config.in b/package/python-setuptools/Config.in
new file mode 100644
index 000000000..63c2b0181
--- /dev/null
+++ b/package/python-setuptools/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_SETUPTOOLS
+ bool "python-setuptools"
+ depends on BR2_PACKAGE_PYTHON
+ select BR2_PACKAGE_PYTHON_ZLIB
+ help
+ Download, build, install, upgrade, and uninstall Python packages.
+
+ http://pypi.python.org/pypi/setuptools
diff --git a/package/python-setuptools/python-setuptools.mk b/package/python-setuptools/python-setuptools.mk
new file mode 100644
index 000000000..b75987bad
--- /dev/null
+++ b/package/python-setuptools/python-setuptools.mk
@@ -0,0 +1,34 @@
+#############################################################
+#
+# python-setuptools
+#
+#############################################################
+
+PYTHON_SETUPTOOLS_VERSION = 0.6c11
+PYTHON_SETUPTOOLS_SOURCE = setuptools-$(PYTHON_SETUPTOOLS_VERSION).tar.gz
+PYTHON_SETUPTOOLS_SITE = http://pypi.python.org/packages/source/s/setuptools
+PYTHON_SETUPTOOLS_DEPENDENCIES = python
+HOST_PYTHON_SETUPTOOLS_DEPENDENCIES = host-python
+
+
+define HOST_PYTHON_SETUPTOOLS_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_SETUPTOOLS_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define HOST_PYTHON_SETUPTOOLS_INSTALL_CMDS
+ (cd $(@D); PYTHONPATH="$(HOST_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages"\
+ $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(HOST_DIR)/usr)
+endef
+
+define PYTHON_SETUPTOOLS_INSTALL_TARGET_CMDS
+ (cd $(@D); PYTHONPATH="$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages"\
+ $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(call GENTARGETS))
+$(eval $(call GENTARGETS,host))
+