summaryrefslogtreecommitdiffstats
path: root/package/python-serial
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-04-13 06:56:50 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-06 09:30:14 +0200
commit2f40b6ae2b27486af2deb999385e3d7f034e4bd5 (patch)
treead2c0397ff4cdb268e60234089bac6325d89b5bb /package/python-serial
parent378ceef8c9ad36a93cc835e617ce3583affba06b (diff)
downloadbuildroot-novena-2f40b6ae2b27486af2deb999385e3d7f034e4bd5.tar.gz
buildroot-novena-2f40b6ae2b27486af2deb999385e3d7f034e4bd5.zip
python-serial: fix shebang
Add the --executable shebang fixup option to the build phase so that the script ends with a proper #!/usr/bin/python interpeter line set. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python-serial')
-rw-r--r--package/python-serial/python-serial.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/python-serial/python-serial.mk b/package/python-serial/python-serial.mk
index fb6b31c59..4bfc355cb 100644
--- a/package/python-serial/python-serial.mk
+++ b/package/python-serial/python-serial.mk
@@ -6,12 +6,12 @@
PYTHON_SERIAL_VERSION = 2.6
PYTHON_SERIAL_SOURCE = pyserial-$(PYTHON_SERIAL_VERSION).tar.gz
-PYTHON_SERIAL_SITE = http://pypi.python.org/packages/source/p/pyserial/
+PYTHON_SERIAL_SITE = http://pypi.python.org/packages/source/p/pyserial
PYTHON_SERIAL_DEPENDENCIES = python
define PYTHON_SERIAL_BUILD_CMDS
- (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build --executable=/usr/bin/python)
endef
define PYTHON_SERIAL_INSTALL_TARGET_CMDS