summaryrefslogtreecommitdiffstats
path: root/package/python-nfc
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-07-20 09:58:12 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-20 21:08:25 +0200
commit45166f30dc40ce810831657c27724a3b5a57f2ad (patch)
treef51eda59cf2f198420f923e228d240da6faaafbb /package/python-nfc
parent1677d40822f032fc09ab271a3d14eb6f445cc91b (diff)
downloadbuildroot-novena-45166f30dc40ce810831657c27724a3b5a57f2ad.tar.gz
buildroot-novena-45166f30dc40ce810831657c27724a3b5a57f2ad.zip
python-nfc: new package
[thomas.petazzoni@free-electrons.com: add patch that creates a standard setup.py file. This allows the .pyc files to be generated at build time, and installed into the target. This is important because by default, Buildroot removes all .py files from the target, to keep only the .pyc files. The python-nfc.mk file was changed to use this setup.py standard build process.] Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-nfc')
-rw-r--r--package/python-nfc/Config.in9
-rw-r--r--package/python-nfc/python-nfc-add-setup-py.patch26
-rw-r--r--package/python-nfc/python-nfc.mk23
3 files changed, 58 insertions, 0 deletions
diff --git a/package/python-nfc/Config.in b/package/python-nfc/Config.in
new file mode 100644
index 000000000..c928ba1f3
--- /dev/null
+++ b/package/python-nfc/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_NFC
+ bool "python-nfc"
+ depends on BR2_PACKAGE_PYTHON
+ select BR2_PACKAGE_LIBUSB
+ select BR2_PACKAGE_LIBUSB_COMPAT
+ help
+ Python module for near field communication.
+
+ https://launchpad.net/nfcpy
diff --git a/package/python-nfc/python-nfc-add-setup-py.patch b/package/python-nfc/python-nfc-add-setup-py.patch
new file mode 100644
index 000000000..307b74984
--- /dev/null
+++ b/package/python-nfc/python-nfc-add-setup-py.patch
@@ -0,0 +1,26 @@
+Add simple setup.py
+
+Having a setup.py allows to easily get the .py files compiled into
+.pyc, which is good because by default, Buildroot only keeps .pyc
+files on the target.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/setup.py
+===================================================================
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,13 @@
++#!/usr/bin/env python
++
++from distutils.core import setup
++
++setup(name='NFC',
++ version='1.0',
++ description='Python NFC',
++ author='Stephen Tiedemann',
++ author_email='stephen.tiedemann@googlemail.com',
++ url='https://launchpad.net/nfcpy',
++ packages=['nfc', 'nfc/dev', 'nfc/llcp', 'nfc/ndef',
++ 'nfc/npp', 'nfc/snep'],
++ )
diff --git a/package/python-nfc/python-nfc.mk b/package/python-nfc/python-nfc.mk
new file mode 100644
index 000000000..90f7c4648
--- /dev/null
+++ b/package/python-nfc/python-nfc.mk
@@ -0,0 +1,23 @@
+#############################################################
+#
+# python-nfc
+#
+#############################################################
+PYTHON_NFC_VERSION = 112
+PYTHON_NFC_SITE = https://launchpad.net/nfcpy
+PYTHON_NFC_SITE_METHOD = bzr
+PYTHON_NFC_DEPENDENCIES = python libusb libusb-compat
+
+define PYTHON_NFC_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_NFC_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+define PYTHON_NFC_UNINSTALL_TARGET_CMDS
+ $(RM) -r $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages/nfc/
+endef
+
+$(eval $(generic-package))