summaryrefslogtreecommitdiffstats
path: root/package/python-id3
diff options
context:
space:
mode:
authorDominik Faessler <faessler@was.ch>2012-05-14 10:33:33 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-14 22:46:05 +0200
commitb3e10d197dbd643b0722c918ac5cd4adadfc3310 (patch)
tree5674fb3186b03e3f661f24d01057e854b8128a7e /package/python-id3
parentef9f0eae3287e5d6cdfc413ff8ffaa74e4ac76fc (diff)
downloadbuildroot-novena-b3e10d197dbd643b0722c918ac5cd4adadfc3310.tar.gz
buildroot-novena-b3e10d197dbd643b0722c918ac5cd4adadfc3310.zip
python-id3: new package
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python-id3')
-rw-r--r--package/python-id3/Config.in9
-rw-r--r--package/python-id3/python-id3.mk21
2 files changed, 30 insertions, 0 deletions
diff --git a/package/python-id3/Config.in b/package/python-id3/Config.in
new file mode 100644
index 000000000..829a65732
--- /dev/null
+++ b/package/python-id3/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_ID3
+ bool "python-id3"
+ depends on BR2_PACKAGE_PYTHON
+ help
+ This module allows one to read and manipulate so-called ID3
+ informational tags on MP3 files through an object-oriented
+ Python interface.
+
+ http://id3-py.sourceforge.net/
diff --git a/package/python-id3/python-id3.mk b/package/python-id3/python-id3.mk
new file mode 100644
index 000000000..e1ed1b606
--- /dev/null
+++ b/package/python-id3/python-id3.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# python-id3
+#
+#############################################################
+
+PYTHON_ID3_VERSION = 1.2
+PYTHON_ID3_SOURCE = id3-py_$(PYTHON_ID3_VERSION).tar.gz
+PYTHON_ID3_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/id3-py
+
+PYTHON_ID3_DEPENDENCIES = python
+
+define PYTHON_ID3_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_ID3_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(call GENTARGETS))