summaryrefslogtreecommitdiffstats
path: root/package/python-dpkt
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2012-01-04 12:30:02 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-07 20:56:33 +0100
commitbdd274110a160ec67fceae642d14a5c3f77a87aa (patch)
tree5f4b25833054b1b147b3eb560a625eb62dc7e346 /package/python-dpkt
parent649915fb753d75a456bf627192204a182aae609f (diff)
downloadbuildroot-novena-bdd274110a160ec67fceae642d14a5c3f77a87aa.tar.gz
buildroot-novena-bdd274110a160ec67fceae642d14a5c3f77a87aa.zip
New package: python-dpkt
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python-dpkt')
-rw-r--r--package/python-dpkt/Config.in11
-rw-r--r--package/python-dpkt/python-dpkt.mk22
2 files changed, 33 insertions, 0 deletions
diff --git a/package/python-dpkt/Config.in b/package/python-dpkt/Config.in
new file mode 100644
index 000000000..aac9f09c9
--- /dev/null
+++ b/package/python-dpkt/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PYTHON_DPKT
+ bool "python-dpkt"
+ depends on BR2_PACKAGE_PYTHON
+ select BR2_PACKAGE_PYTHON_ZLIB
+ help
+ Fast, simple packet creation / parsing, with definitions
+ for the basic TCP/IP protocols.
+
+ http://code.google.com/p/dpkt/
+
+
diff --git a/package/python-dpkt/python-dpkt.mk b/package/python-dpkt/python-dpkt.mk
new file mode 100644
index 000000000..7ac873c95
--- /dev/null
+++ b/package/python-dpkt/python-dpkt.mk
@@ -0,0 +1,22 @@
+#############################################################
+#
+# python-dpkt
+#
+#############################################################
+
+PYTHON_DPKT_VERSION = 1.7
+PYTHON_DPKT_SOURCE = dpkt-$(PYTHON_DPKT_VERSION).tar.gz
+PYTHON_DPKT_SITE = http://dpkt.googlecode.com/files
+
+PYTHON_DPKT_DEPENDENCIES = python
+
+define PYTHON_DPKT_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_DPKT_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(call GENTARGETS))
+