summaryrefslogtreecommitdiffstats
path: root/package/python-bottle
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-12-18 16:14:44 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-18 22:12:54 +0100
commit0a3b19cdc92429ce4552be108283441ef4334a05 (patch)
treef02e8be32d158cd79687bf86227aadd10002dc58 /package/python-bottle
parent50bdab9025f3bcacf4f29e928ed2cba892dfc039 (diff)
downloadbuildroot-novena-0a3b19cdc92429ce4552be108283441ef4334a05.tar.gz
buildroot-novena-0a3b19cdc92429ce4552be108283441ef4334a05.zip
python-bottle: new package
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python-bottle')
-rw-r--r--package/python-bottle/Config.in8
-rw-r--r--package/python-bottle/python-bottle.mk22
2 files changed, 30 insertions, 0 deletions
diff --git a/package/python-bottle/Config.in b/package/python-bottle/Config.in
new file mode 100644
index 000000000..f9b60ca72
--- /dev/null
+++ b/package/python-bottle/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_BOTTLE
+ bool "python-bottle"
+ help
+ Bottle is a fast, simple and lightweight WSGI micro web-framework
+ for Python. It is distributed as a single file module and has no
+ dependencies other than the Python Standard Library.
+
+ http://bottlepy.org
diff --git a/package/python-bottle/python-bottle.mk b/package/python-bottle/python-bottle.mk
new file mode 100644
index 000000000..370b31be0
--- /dev/null
+++ b/package/python-bottle/python-bottle.mk
@@ -0,0 +1,22 @@
+#############################################################
+#
+# python-bottle
+#
+#############################################################
+
+PYTHON_BOTTLE_VERSION = 0.11.4
+PYTHON_BOTTLE_SOURCE = bottle-$(PYTHON_BOTTLE_VERSION).tar.gz
+PYTHON_BOTTLE_SITE = http://pypi.python.org/packages/source/b/bottle
+PYTHON_BOTTLE_DEPENDENCIES = python
+PYTHON_BOTTLE_LICENSE = MIT
+# README.rst refers to the file "LICENSE" but it's not included
+
+define PYTHON_BOTTLE_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_BOTTLE_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(generic-package))