summaryrefslogtreecommitdiffstats
path: root/package/pv
diff options
context:
space:
mode:
authorRoeland Van Praet <roelvp@mind.be>2011-10-07 09:04:26 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-07 10:19:54 +0200
commit7f7cff5239a29e9a8e6436650ea4fad3a736d90d (patch)
tree0727be764eeddc7a6000b2d3fba7727e037bee63 /package/pv
parent811fab1b26f7590c2696801b82347767bbbc0809 (diff)
downloadbuildroot-novena-7f7cff5239a29e9a8e6436650ea4fad3a736d90d.tar.gz
buildroot-novena-7f7cff5239a29e9a8e6436650ea4fad3a736d90d.zip
package: add 'pv' (Pipe-Viewer)
Signed-off-by: Roeland Van Praet <roelvp@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pv')
-rw-r--r--package/pv/Config.in8
-rw-r--r--package/pv/pv-1.2.0-fixld.patch21
-rw-r--r--package/pv/pv.mk11
3 files changed, 40 insertions, 0 deletions
diff --git a/package/pv/Config.in b/package/pv/Config.in
new file mode 100644
index 000000000..671f78e8c
--- /dev/null
+++ b/package/pv/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PV
+ bool "pv"
+ help
+ Pipe Viewer - is a terminal-based tool for
+ monitoring the progress of data through a
+ pipeline.
+
+ http://www.ivarch.com/programs/pv.shtml
diff --git a/package/pv/pv-1.2.0-fixld.patch b/package/pv/pv-1.2.0-fixld.patch
new file mode 100644
index 000000000..9df279de5
--- /dev/null
+++ b/package/pv/pv-1.2.0-fixld.patch
@@ -0,0 +1,21 @@
+[PATCH] fix linker variable
+
+The linker variable LD was always set to 'ld' instead of the value from
+the environment. This breaks any linking, especially when dealing with
+a cross-compiler toolchain.
+The fix takes the CC variable and changes the 'gcc' extension to 'ld'.
+
+Signed-off-by: Roeland Van Praet <roelvp@mind.be>
+---
+diff -ruN a/autoconf/make/vars.mk b/autoconf/make/vars.mk
+--- a/autoconf/make/vars.mk 2010-03-11 00:43:19.000000000 +0100
++++ b/autoconf/make/vars.mk 2011-10-06 15:47:18.000000000 +0200
+@@ -30,7 +30,7 @@
+ @SET_MAKE@
+ SHELL = /bin/sh
+ CC = @CC@
+-LD = ld
++LD = $(CC:gcc=ld)
+ DO_GZIP = @DO_GZIP@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
diff --git a/package/pv/pv.mk b/package/pv/pv.mk
new file mode 100644
index 000000000..5f15f5b54
--- /dev/null
+++ b/package/pv/pv.mk
@@ -0,0 +1,11 @@
+#######################
+#
+# pv - Pipe Viewer
+#
+#######################
+
+PV_VERSION = 1.2.0
+PV_SOURCE = pv-$(PV_VERSION).tar.bz2
+PV_SITE = http://pipeviewer.googlecode.com/files
+
+$(eval $(call AUTOTARGETS))