summaryrefslogtreecommitdiffstats
path: root/package/pptp-linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-02-03 21:53:21 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-04 08:02:22 +0100
commita5b8081b89ebd5f9ff224440376e811c43696866 (patch)
tree7b4f37662279d5b6901eaa012ae840adc02e1738 /package/pptp-linux
parentf72c65a3ae83ffd3d5e3bf0367d53daf437bea28 (diff)
downloadbuildroot-novena-a5b8081b89ebd5f9ff224440376e811c43696866.tar.gz
buildroot-novena-a5b8081b89ebd5f9ff224440376e811c43696866.zip
pptp-linux: fix parallel build
Add a patch to fix a parallel build issue caused by a header file being generated too late. Fixes: http://autobuild.buildroot.org/results/2324974d4818b2657a7df4beee33fc4713d6116f/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pptp-linux')
-rw-r--r--package/pptp-linux/pptp-linux-004-fix-parallel-build.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/pptp-linux/pptp-linux-004-fix-parallel-build.patch b/package/pptp-linux/pptp-linux-004-fix-parallel-build.patch
new file mode 100644
index 000000000..04a797743
--- /dev/null
+++ b/package/pptp-linux/pptp-linux-004-fix-parallel-build.patch
@@ -0,0 +1,23 @@
+Fix parallel build issue
+
+The config.h header file must be created before being used to build
+source files that include it, especially version.c. In order for this
+to happen even in highly-parallel builds, we add a dependency of all
+object files on config.h, in order to ensure it gets generated before
+make attempts to build the object files.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -37,6 +37,8 @@
+
+ all: config.h $(PPTP_BIN) pptpsetup.8
+
++$(PPTP_OBJS): config.h
++
+ $(PPTP_BIN): $(PPTP_OBJS) $(PPTP_DEPS)
+ $(CC) -o $(PPTP_BIN) $(PPTP_OBJS) $(LDFLAGS) $(LIBS)
+